summaryrefslogtreecommitdiffstats
path: root/fs/ubifs/ubifs.mk
diff options
context:
space:
mode:
authorMark Jackson <mpfj-list@newflow.co.uk>2013-04-24 02:29:19 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-04-25 22:43:13 +0200
commita0f3cb1cbeba376a8a8105b58f7f85e63baa11fe (patch)
tree0100cb4c13a78670ce30c5232f95dc4ee3d0a631 /fs/ubifs/ubifs.mk
parent5419651bfa38355b2b2015868811197ef18577d0 (diff)
downloadbuildroot-novena-a0f3cb1cbeba376a8a8105b58f7f85e63baa11fe.tar.gz
buildroot-novena-a0f3cb1cbeba376a8a8105b58f7f85e63baa11fe.zip
fs/ubifs: allow extra options to be passed to ubifs creation tools
Allow extra options to be passed to ubifs creation tools. Signed-off-by: Mark Jackson <mpfj@newflow.co.uk> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'fs/ubifs/ubifs.mk')
-rw-r--r--fs/ubifs/ubifs.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/fs/ubifs/ubifs.mk b/fs/ubifs/ubifs.mk
index 8506dbdb8..dca2e04fb 100644
--- a/fs/ubifs/ubifs.mk
+++ b/fs/ubifs/ubifs.mk
@@ -16,10 +16,12 @@ ifeq ($(BR2_TARGET_ROOTFS_UBIFS_RT_NONE),y)
UBIFS_OPTS += -x none
endif
+UBIFS_OPTS += $(call qstrip,$(BR2_TARGET_ROOTFS_UBIFS_OPTS))
+
ROOTFS_UBIFS_DEPENDENCIES = host-mtd
define ROOTFS_UBIFS_CMD
$(HOST_DIR)/usr/sbin/mkfs.ubifs -d $(TARGET_DIR) $(UBIFS_OPTS) -o $@
endef
-$(eval $(call ROOTFS_TARGET,ubifs)) \ No newline at end of file
+$(eval $(call ROOTFS_TARGET,ubifs))