summaryrefslogtreecommitdiffstats
path: root/fs/initramfs/initramfs.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-04-09 16:16:44 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-04-09 16:16:44 +0200
commit6bb35a38c244b20bbd6e85fd16f69ff2c4f0ed72 (patch)
tree432513fc67dcff844ecf5c48f38bdcf1a9fe3523 /fs/initramfs/initramfs.mk
parentb6ebab842dbb0581526f907bf5b39cad0ac1f756 (diff)
parent0b79c5022d32b15180a18087a0fba5a2f1af5cc7 (diff)
downloadbuildroot-novena-6bb35a38c244b20bbd6e85fd16f69ff2c4f0ed72.tar.gz
buildroot-novena-6bb35a38c244b20bbd6e85fd16f69ff2c4f0ed72.zip
Merge branch 'fs-cleanup' of git://git.busybox.net/~tpetazzoni/git/buildroot
Diffstat (limited to 'fs/initramfs/initramfs.mk')
-rw-r--r--fs/initramfs/initramfs.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/fs/initramfs/initramfs.mk b/fs/initramfs/initramfs.mk
new file mode 100644
index 000000000..cf1fcdbae
--- /dev/null
+++ b/fs/initramfs/initramfs.mk
@@ -0,0 +1,18 @@
+#############################################################
+#
+# Make a initramfs_list file to be used by gen_init_cpio
+# gen_init_cpio is part of the 2.6 linux kernels to build an
+# initial ramdisk filesystem based on cpio
+#
+#############################################################
+
+define ROOTFS_INITRAMFS_INIT_SYMLINK
+ rm -f $(TARGET_DIR)/init
+ ln -s sbin/init $(TARGET_DIR)/init
+endef
+
+define ROOTFS_INITRAMFS_CMD
+ $(SHELL) target/initramfs/gen_initramfs_list.sh -u 0 -g 0 $(TARGET_DIR) > $$@
+endef
+
+$(eval $(call ROOTFS_TARGET,initramfs)) \ No newline at end of file