summaryrefslogtreecommitdiffstats
path: root/boot/at91bootstrap3/Config.in
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2012-09-03 21:33:25 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2012-09-03 21:59:03 +0200
commit32a0454d3c495b12824ef4a0d0341237302d148a (patch)
tree9acc870d089b0028cecdfb1846b828ae4bd38910 /boot/at91bootstrap3/Config.in
parentf9686563b4fd3eed22e26105f7c440f0b74fcac1 (diff)
parentdafa32b3bd75e9d155d075c796fa5b0ecbb9b11b (diff)
downloadbuildroot-novena-32a0454d3c495b12824ef4a0d0341237302d148a.tar.gz
buildroot-novena-32a0454d3c495b12824ef4a0d0341237302d148a.zip
Merge branch 'next'
Conflicts: package/e2fsprogs/e2fsprogs.mk package/libfuse/libfuse.mk package/multimedia/mpd/mpd.mk package/smartmontools/smartmontools.mk Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'boot/at91bootstrap3/Config.in')
-rw-r--r--boot/at91bootstrap3/Config.in53
1 files changed, 53 insertions, 0 deletions
diff --git a/boot/at91bootstrap3/Config.in b/boot/at91bootstrap3/Config.in
new file mode 100644
index 000000000..110f808d6
--- /dev/null
+++ b/boot/at91bootstrap3/Config.in
@@ -0,0 +1,53 @@
+config BR2_TARGET_AT91BOOTSTRAP3
+ depends on BR2_arm926t
+ bool "AT91 Bootstrap 3"
+ help
+ AT91Bootstrap is a first level bootloader for the Atmel AT91
+ devices. It integrates algorithms for:
+ - Device initialization such as clock configuration, PIO settings...
+ - Peripheral drivers such as PIO, PMC or SDRAMC...
+ - Physical media algorithm such as DataFlash, NandFlash, NOR Flash...
+
+if BR2_TARGET_AT91BOOTSTRAP3
+
+config BR2_TARGET_AT91BOOTSTRAP3_CUSTOM_PATCH_DIR
+ string "custom patch dir"
+ help
+ If your board requires custom patches, add the path to the
+ directory containing the patches here. The patches must be
+ named at91bootstrap3-<something>.patch.
+
+ Most users may leave this empty
+
+#
+# Configuration selection
+#
+
+choice
+ prompt "AT91 Bootstrap 3 configuration"
+ default BR2_TARGET_AT91BOOTSTRAP3_USE_DEFCONFIG
+
+config BR2_TARGET_AT91BOOTSTRAP3_USE_DEFCONFIG
+ bool "Using a defconfig"
+
+config BR2_TARGET_AT91BOOTSTRAP3_USE_CUSTOM_CONFIG
+ bool "Using a custom config file"
+
+endchoice
+
+config BR2_TARGET_AT91BOOTSTRAP3_DEFCONFIG
+ string "Defconfig name"
+ depends on BR2_TARGET_AT91BOOTSTRAP3_USE_DEFCONFIG
+ help
+ Name of the at91bootstrap3 defconfig file to use, without the
+ trailing _defconfig. The defconfig is located at
+ board/<processor>/<board>_defconfig in the at91bootstrap3
+ tree.
+
+config BR2_TARGET_AT91BOOTSTRAP3_CUSTOM_CONFIG_FILE
+ string "Configuration file path"
+ depends on BR2_TARGET_AT91BOOTSTRAP3_USE_CUSTOM_CONFIG
+ help
+ Path to the at91bootstrap3 configuration file
+
+endif # BR2_TARGET_AT91BOOTSTRAP3