diff options
author | Thomas Petazzoni <thomas.petazzoni@free-electrons.com> | 2010-06-20 15:08:15 +0200 |
---|---|---|
committer | Thomas Petazzoni <thomas.petazzoni@free-electrons.com> | 2010-07-07 08:14:41 +0200 |
commit | 26082e79af64550d16fb1e314a904456b90a464e (patch) | |
tree | 37209f8e320b1411c61bed08a2f7d326d637bd47 /Makefile | |
parent | 0ab16a01bbe02d37ad2daa007fdb5a0de0ff9eab (diff) | |
download | buildroot-novena-26082e79af64550d16fb1e314a904456b90a464e.tar.gz buildroot-novena-26082e79af64550d16fb1e314a904456b90a464e.zip |
Introduce support for host config cache
We now have for quite some time a configuration cache used to speed-up
the execution of ./configure scripts when compiling programs for the
target. This commit introduces a similar concept when Buildroot
compiles programs for the host.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 8 |
1 files changed, 4 insertions, 4 deletions
@@ -441,12 +441,12 @@ show-targets: @echo $(TARGETS) ifeq ($(BR2_CONFIG_CACHE),y) -# drop configure cache if configuration is changed -$(BUILD_DIR)/tgt-config.cache: $(CONFIG_DIR)/.config +# drop configure caches if configuration is changed +$(BUILD_DIR)/tgt-config.cache $(BUILD_DIR)/host-config.cache: $(CONFIG_DIR)/.config rm -f $@ touch $@ -$(BASE_TARGETS): | $(BUILD_DIR)/tgt-config.cache +$(BASE_TARGETS): | $(BUILD_DIR)/tgt-config.cache $(BUILD_DIR)/host-config.cache endif else # ifeq ($(BR2_HAVE_DOT_CONFIG),y) @@ -580,7 +580,7 @@ endif rm -rf $(CONFIG_DIR)/.config $(CONFIG_DIR)/.config.old $(CONFIG_DIR)/.config.cmd $(CONFIG_DIR)/.auto.deps flush: - rm -f $(BUILD_DIR)/tgt-config.cache + rm -f $(BUILD_DIR)/tgt-config.cache $(BUILD_DIR)/host-config.cache %_defconfig: $(TOPDIR)/configs/%_defconfig cp $^ $(CONFIG_DIR)/.config |