summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-01-25 16:24:46 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-01-25 16:24:46 +0100
commit0eef30440e9597b2c0b9c7a0340a3986a7ea2a65 (patch)
treef8e74a929418c8085bc09dd5606a10e356923c74 /Makefile
parent4c6a451ac9fab16abcda5834ed4a9b728091ab9e (diff)
parent6ea3c8bd4dabe2b11a8beecb6a641336e6e90f3c (diff)
downloadbuildroot-novena-0eef30440e9597b2c0b9c7a0340a3986a7ea2a65.tar.gz
buildroot-novena-0eef30440e9597b2c0b9c7a0340a3986a7ea2a65.zip
Merge branch 'for-2011.02/python-bump' of git://git.busybox.net/~tpetazzoni/git/buildroot
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index cf2a7dcf6..a5a37a1ee 100644
--- a/Makefile
+++ b/Makefile
@@ -438,6 +438,12 @@ ifneq ($(BR2_HAVE_DOCUMENTATION),y)
rm -rf $(TARGET_DIR)/usr/share/gtk-doc
-rmdir $(TARGET_DIR)/usr/share 2>/dev/null
endif
+ifeq ($(BR2_PACKAGE_PYTHON_PY_ONLY),y)
+ find $(TARGET_DIR)/usr/lib/ -name '*.pyc' -print0 | xargs -0 rm -f
+endif
+ifeq ($(BR2_PACKAGE_PYTHON_PYC_ONLY),y)
+ find $(TARGET_DIR)/usr/lib/ -name '*.py' -print0 | xargs -0 rm -f
+endif
find $(TARGET_DIR) -type f -perm +111 '!' -name 'libthread_db*.so*' | \
xargs $(STRIPCMD) 2>/dev/null || true
find $(TARGET_DIR)/lib/modules -type f -name '*.ko' | \