summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-11-04 13:56:00 +0000
committerEric Andersen <andersen@codepoet.org>2003-11-04 13:56:00 +0000
commit5833504dadb891dad80397c04ce05f43e8912882 (patch)
treedfa6d9d0142b47cc22ee3c1e3e8f3dc74ae070c3
parent9d82281e6736313e09196dd43f7ec1461b99872c (diff)
downloadbuildroot-novena-5833504dadb891dad80397c04ce05f43e8912882.tar.gz
buildroot-novena-5833504dadb891dad80397c04ce05f43e8912882.zip
minor changes to accomodate the config system updates
-rw-r--r--make/uclibc.mk4
-rw-r--r--sources/uClibc.config28
2 files changed, 16 insertions, 16 deletions
diff --git a/make/uclibc.mk b/make/uclibc.mk
index e6ab1652a..2a30490f8 100644
--- a/make/uclibc.mk
+++ b/make/uclibc.mk
@@ -24,13 +24,13 @@ $(UCLIBC_DIR)/.unpacked: $(DL_DIR)/$(UCLIBC_SOURCE)
touch $(UCLIBC_DIR)/.unpacked
$(UCLIBC_DIR)/.configured: $(UCLIBC_DIR)/.unpacked $(BUILD_DIR)/linux/.configured
- perl -i -p -e 's,^CROSS=.*,TARGET_ARCH=$(ARCH)\nCROSS=$(TARGET_CROSS),g' \
- $(UCLIBC_DIR)/Rules.mak
+ perl -i -p -e 's,^CROSS=.*,CROSS=$(TARGET_CROSS),g' $(UCLIBC_DIR)/Rules.mak
ifeq ($(ENABLE_LOCALE),true)
cp $(SOURCE_DIR)/uClibc.config-locale $(UCLIBC_DIR)/.config
else
cp $(SOURCE_DIR)/uClibc.config $(UCLIBC_DIR)/.config
endif
+ perl -i -p -e 's,^TARGET_[a-z].*,TARGET_$(ARCH)=y,g' $(UCLIBC_DIR)/.config
perl -i -p -e 's,^KERNEL_SOURCE=.*,KERNEL_SOURCE=\"$(LINUX_DIR)\",g' \
$(UCLIBC_DIR)/.config
perl -i -p -e 's,^RUNTIME_PREFIX=.*,RUNTIME_PREFIX=\"$(STAGING_DIR)\",g' \
diff --git a/sources/uClibc.config b/sources/uClibc.config
index d858814f4..f023406f6 100644
--- a/sources/uClibc.config
+++ b/sources/uClibc.config
@@ -1,20 +1,20 @@
#
# Automatically generated make config: don't edit
#
-# TARGET_ALPHA is not set
-# TARGET_ARM is not set
-# TARGET_CRIS is not set
-# TARGET_E1 is not set
-# TARGET_H8300 is not set
-TARGET_I386=y
-# TARGET_I960 is not set
-# TARGET_M68K is not set
-# TARGET_MICROBLAZE is not set
-# TARGET_MIPS is not set
-# TARGET_POWERPC is not set
-# TARGET_SH is not set
-# TARGET_SPARC is not set
-# TARGET_V850 is not set
+# TARGET_alpha is not set
+# TARGET_arm is not set
+# TARGET_cris is not set
+# TARGET_e1 is not set
+# TARGET_h8300 is not set
+TARGET_i386=y
+# TARGET_i960 is not set
+# TARGET_m68k is not set
+# TARGET_microblaze is not set
+# TARGET_mips is not set
+# TARGET_powerpc is not set
+# TARGET_sh is not set
+# TARGET_sparc is not set
+# TARGET_v850 is not set
#
# Target Architecture Features and Options