aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkos Chandras <markos.chandras@imgtec.com>2012-03-11 14:15:00 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2012-03-13 13:12:02 +0100
commitce6727f63046c49d5e778af72e7096ff2e3ad82c (patch)
tree1f1f17c5ca8ac81078f5bb4d4d4291ac3fd065ce
parent2b91ab7a20cf17db16cf3c8a93ef4e50dfb585b7 (diff)
downloadbuildroot-novena-ce6727f63046c49d5e778af72e7096ff2e3ad82c.tar.gz
buildroot-novena-ce6727f63046c49d5e778af72e7096ff2e3ad82c.zip
libethumb: Fix automagic dependencies on libedbus and libexif
libethumb will determine during configuration phase whether to build the optional libexif and libedbus modules. It will enable this modules if libedbus or libexif are present on the target system. Therefore, we need to add these packages as optional dependencies to libethumb. Signed-off-by: Markos Chandras <markos.chandras@imgtec.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/efl/libethumb/libethumb.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/efl/libethumb/libethumb.mk b/package/efl/libethumb/libethumb.mk
index 16b2ba955..617de0d79 100644
--- a/package/efl/libethumb/libethumb.mk
+++ b/package/efl/libethumb/libethumb.mk
@@ -13,4 +13,12 @@ LIBETHUMB_DEPENDENCIES = libeina libevas libecore libedje host-libedje
LIBETHUMB_CONF_OPT = --with-edje-cc=$(HOST_DIR)/usr/bin/edje_cc
+ifeq ($(BR2_PACKAGE_LIBEXIF),y)
+LIBETHUMB_DEPENDENCIES += libexif
+endif
+
+ifeq ($(BR2_PACKAGE_LIBEDBUS),y)
+LIBETHUMB_DEPENDENCIES += libedbus
+endif
+
$(eval $(call AUTOTARGETS))