aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Novoa III <mjn3@codepoet.org>2003-11-25 14:45:40 +0000
committerManuel Novoa III <mjn3@codepoet.org>2003-11-25 14:45:40 +0000
commitbbf2a9074b076ab88b09a4cf5992da410ef2ab23 (patch)
treee7cd800caea579669c71627c4cdce8f34873b4e8
parentce6884732d2a4b644e556922737cb1274008f635 (diff)
downloadbuildroot-novena-bbf2a9074b076ab88b09a4cf5992da410ef2ab23.tar.gz
buildroot-novena-bbf2a9074b076ab88b09a4cf5992da410ef2ab23.zip
Remove libgcc_eh hack. Things now build as they are supposed to.
-rw-r--r--make/gcc-3.3.mk2
1 files changed, 0 insertions, 2 deletions
diff --git a/make/gcc-3.3.mk b/make/gcc-3.3.mk
index 0a12d043c..1976f6293 100644
--- a/make/gcc-3.3.mk
+++ b/make/gcc-3.3.mk
@@ -445,8 +445,6 @@ $(TARGET_DIR)/usr/bin/gcc: $(GCC_BUILD_DIR3)/.compiled
-mv $(TARGET_DIR)/lib/*.a $(TARGET_DIR)/usr/lib/
-mv $(TARGET_DIR)/lib/*.la $(TARGET_DIR)/usr/lib/
rm -f $(TARGET_DIR)/lib/libstdc++.so*
- # A nasty hack to work around g++ adding -lgcc_eh to the link
- -(cd $(TARGET_DIR)/usr/lib/gcc-lib/$(ARCH)-linux/$(GCC_VERSION)/ ; ln -s libgcc.a libgcc_eh.a)
# Make sure gcc does not think we are cross compiling
$(SED) "s/^1/0/;" $(TARGET_DIR)/usr/lib/gcc-lib/$(ARCH)-linux/$(GCC_VERSION)/specs
-(cd $(TARGET_DIR)/bin; find -type f | xargs $(STRIP) > /dev/null 2>&1)