summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2002-08-28 21:28:19 +0000
committerEric Andersen <andersen@codepoet.org>2002-08-28 21:28:19 +0000
commitf952c942fb164ca487fbd881e891749cdfe66940 (patch)
tree51444b97de25036ce0d053e3961d95002c7954f2
parentc75e4a1f62968dabab546e0177c466e2ea8fb976 (diff)
downloadbuildroot-novena-f952c942fb164ca487fbd881e891749cdfe66940.tar.gz
buildroot-novena-f952c942fb164ca487fbd881e891749cdfe66940.zip
Update to uClibc 0.9.15. decouple kernel, toolchain, and uClibc.
-Erik
-rw-r--r--Makefile4
-rw-r--r--make/uclibc.mk5
-rw-r--r--make/uclibc_toolchain.mk48
-rw-r--r--make/user-mode-linux.mk9
-rw-r--r--make/valgrind.mk4
5 files changed, 26 insertions, 44 deletions
diff --git a/Makefile b/Makefile
index 220feabee..c711196b9 100644
--- a/Makefile
+++ b/Makefile
@@ -39,7 +39,7 @@ USE_UCLIBC_TOOLCHAIN:=false
# Enable this to use the uClibc daily snapshot instead of a released
# version. Daily snapshots may contain new features and bugfixes. Or
# they may not even compile at all, depending on what Erik is doing...
-USE_UCLIBC_SNAPSHOT:=true
+USE_UCLIBC_SNAPSHOT:=false
# Enable this to use the busybox daily snapshot instead of a released
# version. Daily snapshots may contain new features and bugfixes. Or
@@ -58,7 +58,7 @@ ifeq ($(USE_UCLIBC_TOOLCHAIN),true)
TARGETS=uclibc_toolchain
endif
-TARGETS+=user-mode-linux busybox tinylogin #ncurses gdb strace valgrind
+TARGETS+=user-mode-linux busybox tinylogin ncurses gdb strace valgrind db
# Pick your root filesystem type.
TARGETS+=ext2root
diff --git a/make/uclibc.mk b/make/uclibc.mk
index 5d856452d..3b8418fcc 100644
--- a/make/uclibc.mk
+++ b/make/uclibc.mk
@@ -29,8 +29,8 @@ UCLIBC_DIR=$(BUILD_DIR)/uClibc
UCLIBC_SOURCE=uClibc-snapshot.tar.bz2
UCLIBC_SITE:=ftp://www.uclibc.org/uClibc
else
-UCLIBC_DIR:=$(BUILD_DIR)/uClibc-0.9.14
-UCLIBC_SOURCE:=uClibc-0.9.14.tar.bz2
+UCLIBC_DIR:=$(BUILD_DIR)/uClibc-0.9.15
+UCLIBC_SOURCE:=uClibc-0.9.15.tar.bz2
UCLIBC_SITE:=http://www.kernel.org/pub/linux/libs/uclibc
endif
#UCLIBC_PATCH=$(SOURCE_DIR)/uClibc.patch
@@ -66,7 +66,6 @@ $(UCLIBC_DIR)/Config: $(UCLIBC_DIR)/.unpacked
--kernel_dir=$(LINUX_DIR) \
--float=true \
--c99_math=true \
- --long_long=true \
--float=true \
--shadow=true \
--threads=true \
diff --git a/make/uclibc_toolchain.mk b/make/uclibc_toolchain.mk
index b07d3a821..5642e465c 100644
--- a/make/uclibc_toolchain.mk
+++ b/make/uclibc_toolchain.mk
@@ -33,10 +33,6 @@ HOSTCC:=gcc
HAS_MMU:=true
-# Enable this to use the uClibc daily snapshot instead of a released
-# version. Daily snapshots may contain new features and bugfixes. Or
-# they may not even compile at all, depending on what Erik is doing...
-USE_UCLIBC_SNAPSHOT:=true
#############################################################
#
# You should probably leave this stuff alone unless you are
@@ -56,11 +52,11 @@ NATIVE_ARCH:= ${shell uname -m | sed \
-e 's/sh[234].*/sh/' \
-e 's/mips.*/mips/' \
}
-ifeq ($(strip $(ARCH)),$(strip $(NATIVE_ARCH)))
-CROSSARG=
-else
+#ifeq ($(strip $(ARCH)),$(strip $(NATIVE_ARCH)))
+#CROSSARG=
+#else
CROSSARG=--cross=$(STAGING_DIR)/bin/$(ARCH)-uclibc-
-endif
+#endif
ifneq ($(HAS_MMU),true)
NOMMU:=nommu
endif
@@ -84,14 +80,14 @@ UCLIBC_DIR=$(BUILD_DIR)/uClibc
UCLIBC_SOURCE=uClibc-snapshot.tar.bz2
UCLIBC_SITE:=ftp://www.uclibc.org/uClibc
else
-UCLIBC_DIR:=$(BUILD_DIR)/uClibc-0.9.14
-UCLIBC_SOURCE:=uClibc-0.9.14.tar.bz2
+UCLIBC_DIR:=$(BUILD_DIR)/uClibc-0.9.15
+UCLIBC_SOURCE:=uClibc-0.9.15.tar.bz2
UCLIBC_SITE:=http://www.kernel.org/pub/linux/libs/uclibc
endif
GCC_SITE:=ftp://ftp.gnu.org/gnu/gcc/
-GCC_SOURCE:=gcc-3.1.1.tar.gz
-GCC_DIR:=$(BUILD_DIR)/gcc-3.1.1
+GCC_SOURCE:=gcc-3.2.tar.gz
+GCC_DIR:=$(BUILD_DIR)/gcc-3.2
GCC_BUILD_DIR1:=$(BUILD_DIR)/gcc-initial
GCC_BUILD_DIR2:=$(BUILD_DIR)/gcc-final
@@ -122,7 +118,7 @@ $(BUILD_DIR)/.setup:
# Setup some initial stuff
#
#############################################################
-uclibc_toolchain: gcc_final
+uclibc_toolchain: uclibc gcc_final
uclibc_toolchain-clean: gcc_final-clean uclibc-clean gcc_initial-clean binutils-clean
@@ -132,27 +128,6 @@ uclibc_toolchain-dirclean: gcc_final-dirclean uclibc-dirclean gcc_initial-dircle
#############################################################
#
-# Setup the kernel headers, but don't compile anything for the target yet,
-# since we still need to build a cross-compiler to do that little task for
-# us... Try to work around this little chicken-and-egg problem..
-#
-#############################################################
-ifeq ($(LINUX_DIR),)
-LINUX_DIR:=$(BUILD_DIR)/linux
-endif
-$(LINUX_DIR)/.cross_compiler_set: $(BUILD_DIR)/.setup $(LINUX_DIR)/.configured
- #If we were cross compiling the kernel, we would need to do this,
- # but for UserMode Linux, we can skip this step....
- #perl -i -p -e "s,^CROSS_COMPILE.*,\
- # CROSS_COMPILE=$(STAGING_DIR)/bin/$(ARCH)-uclibc-,g;" \
- # $(LINUX_DIR)/Makefile
- touch $(LINUX_DIR)/.cross_compiler_set
-
-linux_headers: $(LINUX_DIR)/.cross_compiler_set
-
-
-#############################################################
-#
# build binutils
#
#############################################################
@@ -293,7 +268,6 @@ $(UCLIBC_DIR)/.configured: $(UCLIBC_DIR)/.unpacked
--kernel_dir=$(LINUX_DIR) \
--float=true \
--c99_math=true \
- --long_long=true \
--float=true \
--shadow=true \
--threads=true \
@@ -453,8 +427,8 @@ $(BUILD_DIR)/.stripped: $(BUILD_DIR)/.shuffled
-R .note -R .comment $(STAGING_DIR)/lib/*.so*;
touch $(BUILD_DIR)/.stripped
-#gcc_final: uclibc $(BUILD_DIR)/.stripped
-gcc_final: uclibc $(BUILD_DIR)/.shuffled
+#gcc_final: $(BUILD_DIR)/.stripped
+gcc_final: $(BUILD_DIR)/.shuffled
gcc_final-clean:
rm -rf $(GCC_BUILD_DIR2)
diff --git a/make/user-mode-linux.mk b/make/user-mode-linux.mk
index 5b0750230..79968a769 100644
--- a/make/user-mode-linux.mk
+++ b/make/user-mode-linux.mk
@@ -55,3 +55,12 @@ user-mode-linux_clean: clean
user-mode-linux-dirclean:
rm -rf $(UMLINUX_DIR)
+#############################################################
+#
+# Setup the kernel headers, but don't compile anything for the target yet,
+# since we still need to build a cross-compiler to do that little task for
+# us... Try to work around this little chicken-and-egg problem..
+#
+#############################################################
+linux_headers: $(UMLINUX_DIR)/.configured
+
diff --git a/make/valgrind.mk b/make/valgrind.mk
index 38c0f404e..50ffa23aa 100644
--- a/make/valgrind.mk
+++ b/make/valgrind.mk
@@ -5,8 +5,8 @@
#############################################################
VALGRIND_SITE:=http://developer.kde.org/~sewardj
-VALGRIND_DIR:=$(BUILD_DIR)/valgrind-1.0.0
-VALGRIND_SOURCE:=valgrind-1.0.0.tar.bz2
+VALGRIND_DIR:=$(BUILD_DIR)/valgrind-1.0.1
+VALGRIND_SOURCE:=valgrind-1.0.1.tar.bz2
VALGRIND_PATCH:=$(SOURCE_DIR)/valgrind.patch
$(DL_DIR)/$(VALGRIND_SOURCE):