summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-11-05 01:34:17 +0000
committerEric Andersen <andersen@codepoet.org>2003-11-05 01:34:17 +0000
commitd39951475283e231707df7f86a077036e7d35a00 (patch)
treec9493d52a55558d463fe60ce3b38aa67d9abe98a
parent55b7ab982f13e72386ddf7621224acc198b50420 (diff)
downloadbuildroot-novena-d39951475283e231707df7f86a077036e7d35a00.tar.gz
buildroot-novena-d39951475283e231707df7f86a077036e7d35a00.zip
A bit more wiggling to prevent asking about the target
architecture when possible, since we already know the correct answer.
-rw-r--r--make/uclibc.mk3
-rw-r--r--sources/uClibc.config17
2 files changed, 17 insertions, 3 deletions
diff --git a/make/uclibc.mk b/make/uclibc.mk
index a547eaf2b..c5c69c5d3 100644
--- a/make/uclibc.mk
+++ b/make/uclibc.mk
@@ -44,7 +44,8 @@ ifeq ($(ENABLE_LOCALE),true)
else
cp $(SOURCE_DIR)/uClibc.config $(UCLIBC_DIR)/.config
endif
- perl -i -p -e 's,^TARGET_[a-z].*,TARGET_$(UCLIBC_TARGET_ARCH)=y,g' $(UCLIBC_DIR)/.config
+ perl -i -p -e 's,^.*TARGET_$(UCLIBC_TARGET_ARCH).*,TARGET_$(UCLIBC_TARGET_ARCH)=y,g' \
+ $(UCLIBC_DIR)/.config
perl -i -p -e 's,^TARGET_ARCH.*,TARGET_ARCH=\"$(UCLIBC_TARGET_ARCH)\",g' $(UCLIBC_DIR)/.config
perl -i -p -e 's,^KERNEL_SOURCE=.*,KERNEL_SOURCE=\"$(LINUX_DIR)\",g' \
$(UCLIBC_DIR)/.config
diff --git a/sources/uClibc.config b/sources/uClibc.config
index b87042da2..d38ca852c 100644
--- a/sources/uClibc.config
+++ b/sources/uClibc.config
@@ -1,13 +1,26 @@
#
# Automatically generated make config: don't edit
#
-TARGET_i386=y
+# TARGET_alpha is not set
+# TARGET_arm is not set
+# TARGET_cris is not set
+# TARGET_e1 is not set
+# TARGET_h8300 is not set
+# TARGET_i386 is not set
+# TARGET_i960 is not set
+# TARGET_m68k is not set
+# TARGET_microblaze is not set
+# TARGET_mips is not set
+# TARGET_powerpc is not set
+# TARGET_sh is not set
+# TARGET_sparc is not set
+# TARGET_v850 is not set
#
# Target Architecture Features and Options
#
HAVE_ELF=y
-TARGET_ARCH="i386"
+TARGET_ARCH="none"
UCLIBC_HAS_FLOATS=y
# ARCH_HAS_NO_FPU is not set
HAS_FPU=y