summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanomi Manchego <danomimanchego123@gmail.com>2012-12-06 16:37:07 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-12-09 21:46:40 +0100
commit63eabbb11ec31e6629169c8258b4c73b90b6e8b9 (patch)
tree9bcd9c9da786f22288eebfba16f5fa210b756766
parentfc3a89d1cde8da2df17fdcc42289f330c2711d9b (diff)
downloadbuildroot-novena-63eabbb11ec31e6629169c8258b4c73b90b6e8b9.tar.gz
buildroot-novena-63eabbb11ec31e6629169c8258b4c73b90b6e8b9.zip
pkg-download.mk: fix multiple matches in shallow clone test
Move the git reference directly to git-ls-remote rather than piping the output to grep, to help avoid reporting partial matches rather than the actual requested reference. Also, add quotes to protest "test" from failing when multiple strings are reported. Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/pkg-download.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/pkg-download.mk b/package/pkg-download.mk
index ea01b0530..1705fcd8e 100644
--- a/package/pkg-download.mk
+++ b/package/pkg-download.mk
@@ -82,7 +82,7 @@ domainseparator=$(if $(1),$(1),/)
define DOWNLOAD_GIT
test -e $(DL_DIR)/$($(PKG)_SOURCE) || \
(pushd $(DL_DIR) > /dev/null && \
- ((test `git ls-remote $($(PKG)_SITE) | cut -f 2- | grep $($(PKG)_DL_VERSION)` && \
+ ((test "`git ls-remote $($(PKG)_SITE) $($(PKG)_DL_VERSION)`" && \
echo "Doing shallow clone" && \
$(GIT) clone --depth 1 -b $($(PKG)_DL_VERSION) --bare $($(PKG)_SITE) $($(PKG)_BASE_NAME)) || \
(echo "Doing full clone" && \