diff options
author | Peter Korsgaard <jacmet@sunsite.dk> | 2010-05-21 08:53:34 +0200 |
---|---|---|
committer | Peter Korsgaard <jacmet@sunsite.dk> | 2010-05-21 08:53:34 +0200 |
commit | bb81787ae1f8b1d8c513f42766c2155b66feaf84 (patch) | |
tree | 3c2219b6ad8f802882a2d5954e3a69a3c152c7d8 | |
parent | 484d15dea6f3175eb5b999592a7f4bb9d101c68a (diff) | |
download | buildroot-novena-bb81787ae1f8b1d8c513f42766c2155b66feaf84.tar.gz buildroot-novena-bb81787ae1f8b1d8c513f42766c2155b66feaf84.zip |
qt: update x86x86fix for 32bit pc hosts
The recent change to use config.guess to figure out GNU_HOST_NAME
broken the x86x86fix detection for 32bit hosts, as config.guess
returns something like i686-pc-linux-gnu rather than something with
*-unknown-linux-* like we used to use.
Fix it by simply looking for "linux" instead.
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r-- | CHANGES | 2 | ||||
-rw-r--r-- | package/qt/qt.mk | 2 |
2 files changed, 2 insertions, 2 deletions
@@ -2,7 +2,7 @@ Fixes all over the tree. - Updated/fixed packages: aumix, avahi, busybox, mtd-utils, ntp + Updated/fixed packages: aumix, avahi, busybox, mtd-utils, ntp, qt Issues resolved (http://bugs.uclibc.org): diff --git a/package/qt/qt.mk b/package/qt/qt.mk index 4f42e59e8..aaf965e3c 100644 --- a/package/qt/qt.mk +++ b/package/qt/qt.mk @@ -372,7 +372,7 @@ BR2_PACKAGE_QT_EMB_PLATFORM:=$(call qstrip,$(BR2_PACKAGE_QT_EMB_PLATFORM)) # x86x86fix # Workaround Qt Embedded bug when crosscompiling for x86 under x86 with linux # host. It's unclear if this would happen on other hosts. -ifneq ($(findstring unknown-linux,$(GNU_HOST_NAME)),) +ifneq ($(findstring linux,$(GNU_HOST_NAME)),) ifneq ($(findstring x86,$(BR2_PACKAGE_QT_EMB_PLATFORM)),) QT_CONFIGURE+= -platform linux-g++ endif |