diff options
author | Thomas Petazzoni <thomas.petazzoni@free-electrons.com> | 2010-04-28 23:40:43 +0200 |
---|---|---|
committer | Peter Korsgaard <jacmet@sunsite.dk> | 2010-05-02 23:25:15 +0200 |
commit | 6af9c84a5192c2d250b47ba06808dc08ec4e17f2 (patch) | |
tree | e6c7a605403e04d1ac138f44aa5059bb665004aa | |
parent | 7dfa3b3fb42adabe5bbf36ea32909f427561ca59 (diff) | |
download | buildroot-novena-6af9c84a5192c2d250b47ba06808dc08ec4e17f2.tar.gz buildroot-novena-6af9c84a5192c2d250b47ba06808dc08ec4e17f2.zip |
libxslt: fix host compilation
Do not build against libgcrypt on the host, since we don't build
libgcrypt ourself, and it might fail even when libgcrypt is installed
on the host:
...configure...
checking for libgcrypt-config... /usr/bin/libgcrypt-config
Crypto extensions will be available.
...build...
gcc: /usr/lib/libgcrypt.so: No such file or directory
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r-- | CHANGES | 2 | ||||
-rw-r--r-- | package/libxslt/libxslt.mk | 3 |
2 files changed, 3 insertions, 2 deletions
@@ -15,7 +15,7 @@ Updated/fixed packages: alsa-utils, busybox, dnsmasq, dosfstools, e2fsprogs, eeprog, fbv, freetype, haserl, hostapd, iperf, iptables, iw, less, libaio,libdrm, libgcrypt, libglib2, - libpng, libxml2, lua, matchbox, mdadm, memstat, mesa3d, + libpng, libxml2, libxslt, lua, matchbox, mdadm, memstat, mesa3d, mtd-utils, nano, openssl, pciutils, php, pixman, portage, pppd, pthread-stubs, python, qt, radvd, samba, setserial, squashfs, tslib, usb_modeswith, wget, xdata_xcursor-themes, diff --git a/package/libxslt/libxslt.mk b/package/libxslt/libxslt.mk index 407924d4d..e77663df2 100644 --- a/package/libxslt/libxslt.mk +++ b/package/libxslt/libxslt.mk @@ -27,7 +27,8 @@ LIBXSLT_DEPENDENCIES = libxml2 $(LIBXSLT_DEPENDENCIES_EXTRA) HOST_LIBXSLT_CONF_OPT = --enable-shared \ --without-debugging \ --without-python \ - --without-threads + --without-threads \ + --without-crypto HOST_LIBXSLT_DEPENDENCIES = host-libxml2 |