summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-05-16 17:38:29 +0000
committerEric Andersen <andersen@codepoet.org>2005-05-16 17:38:29 +0000
commitc8144b92b43e854a8621e874a63a95270e52bf63 (patch)
tree876b888e39de6414a19b90f6ef4cc579dd3b0da7
parent278a121fadd564ea189702b8d0ad9f2612c46eb1 (diff)
downloadbuildroot-novena-c8144b92b43e854a8621e874a63a95270e52bf63.tar.gz
buildroot-novena-c8144b92b43e854a8621e874a63a95270e52bf63.zip
This patch updates the e2fsprogs package to build the 1.37 version of
e2fsprogs. This version of e2fsprogs adds additional features and increases preformance. I've also change the configuration to build all of e2fsprogs dynamicly linked. This reduces the size of the individual binaries considerably. http://bugs.uclibc.org/view.php?id=258
-rw-r--r--package/e2fsprogs/e2fsprogs.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/e2fsprogs/e2fsprogs.mk b/package/e2fsprogs/e2fsprogs.mk
index ebbceae75..573d49e7d 100644
--- a/package/e2fsprogs/e2fsprogs.mk
+++ b/package/e2fsprogs/e2fsprogs.mk
@@ -3,7 +3,7 @@
# e2fsprogs
#
#############################################################
-E2FSPROGS_VER:=1.35
+E2FSPROGS_VER:=1.37
E2FSPROGS_SOURCE=e2fsprogs-$(E2FSPROGS_VER).tar.gz
E2FSPROGS_SITE=http://telia.dl.sourceforge.net/sourceforge/e2fsprogs
E2FSPROGS_DIR=$(BUILD_DIR)/e2fsprogs-$(E2FSPROGS_VER)
@@ -41,9 +41,10 @@ $(E2FSPROGS_DIR)/.configured: $(E2FSPROGS_DIR)/.unpacked
--localstatedir=/var \
--mandir=/usr/man \
--infodir=/usr/info \
- --disable-elf-shlibs --disable-swapfs \
+ --enable-elf-shlibs --enable-dynamic-e2fsck --disable-swapfs \
--disable-debugfs --disable-imager \
--disable-resizer --enable-fsck \
+ --disable-e2initrd-helper \
--without-catgets $(DISABLE_NLS) \
);
touch $(E2FSPROGS_DIR)/.configured