summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-01-21 06:41:00 +0000
committerEric Andersen <andersen@codepoet.org>2003-01-21 06:41:00 +0000
commitc1701b3e17ab8da35678926dbf7f909d7854f7e0 (patch)
tree8c71f565f8d6c046311f864a3d0db26cf660fd8c
parent075eb13aa98aced33cc5aefc3e232056eca092c6 (diff)
downloadbuildroot-novena-c1701b3e17ab8da35678926dbf7f909d7854f7e0.tar.gz
buildroot-novena-c1701b3e17ab8da35678926dbf7f909d7854f7e0.zip
pcmcia update
-rw-r--r--make/pcmcia.mk2
-rw-r--r--sources/pcmcia.patch13
-rwxr-xr-xsources/target_skeleton/etc/init.d/S30pcmcia20
3 files changed, 1 insertions, 34 deletions
diff --git a/make/pcmcia.mk b/make/pcmcia.mk
index e278ea642..51f634df3 100644
--- a/make/pcmcia.mk
+++ b/make/pcmcia.mk
@@ -78,7 +78,7 @@ $(TARGET_DIR)/sbin/cardmgr: $(PCMCIA_DIR)/cardmgr/cardmgr
rm -f $(TARGET_DIR)/usr/share/pnp.ids $(TARGET_DIR)/sbin/lspnp $(TARGET_DIR)/sbin/setpnp;
rm -f $(TARGET_DIR)/sbin/pcinitrd
rm -f $(TARGET_DIR)/sbin/probe
- cp $(PCMCIA_DIR)/etc/rc.pcmcia $(TARGET_DIR)/etc/init.d/
+ cp $(PCMCIA_DIR)/etc/rc.pcmcia $(TARGET_DIR)/etc/init.d/S30pcmcia
chmod -R u+w $(TARGET_DIR)/etc/pcmcia/*
pcmcia: uclibc $(TARGET_DIR)/sbin/cardmgr
diff --git a/sources/pcmcia.patch b/sources/pcmcia.patch
index 42a16175d..38c517040 100644
--- a/sources/pcmcia.patch
+++ b/sources/pcmcia.patch
@@ -39,16 +39,3 @@ diff -urN pcmcia-cs-3.1.33.orig/etc/shared pcmcia-cs-3.1.33/etc/shared
# Infrastructure network for older cards
#module "ray_cs" opts "net_type=1 essid=ESSID1"
# Infrastructure network for WebGear
---- pcmcia-cs-3.2.1/Configure.orig Thu Aug 8 00:38:15 2002
-+++ pcmcia-cs-3.2.1/Configure Tue Sep 10 05:41:24 2002
-@@ -669,6 +669,10 @@
- >/dev/null 2>&1 ; then
- CONFIG_IEEE1394=n
- fi
-+
-+# Hack to disable network stuff for the time being...
-+CONFIG_INET=n
-+
- printconfig
- echo ""
-
diff --git a/sources/target_skeleton/etc/init.d/S30pcmcia b/sources/target_skeleton/etc/init.d/S30pcmcia
deleted file mode 100755
index a3906c3f4..000000000
--- a/sources/target_skeleton/etc/init.d/S30pcmcia
+++ /dev/null
@@ -1,20 +0,0 @@
-# Select the module that is correct for your hardware
-
-PCIC=yenta_socket
-#PCIC=i82365
-#PCIC=tcic
-#PCIC=sa1100_cs
-
-# Load up all the pcmcia modules
-/sbin/modprobe pcmcia_core
-/sbin/modprobe $PCIC
-/sbin/modprobe ds
-
-if [ $? != 0 ] ; then
- echo "pcmcia support not detected";
- exit 0;
-fi
-
-/sbin/cardmgr -m /lib/modules
-
-exit 0;