diff options
author | Mike Frysinger <vapier@gentoo.org> | 2005-12-27 08:42:13 +0000 |
---|---|---|
committer | Mike Frysinger <vapier@gentoo.org> | 2005-12-27 08:42:13 +0000 |
commit | 70ea98efbbfb15a6811d298276c436847827f348 (patch) | |
tree | bf0564e565588dbe77e3d96b93e6bc018bd0c5a1 | |
parent | afe8857daf1d4b14b5fb45fe7ad7048f70393477 (diff) | |
download | buildroot-novena-70ea98efbbfb15a6811d298276c436847827f348.tar.gz buildroot-novena-70ea98efbbfb15a6811d298276c436847827f348.zip |
add an option for the --build so cygwin users can utilize buildroot
-rw-r--r-- | Config.in | 13 | ||||
-rw-r--r-- | package/Makefile.in | 2 |
2 files changed, 14 insertions, 1 deletions
@@ -178,6 +178,19 @@ config BR2_TOPDIR_SUFFIX build_ARCH -> build_ARCH_[SUFFIX] toolchain_build_ARCH -> toolchain_build_ARCH_[SUFFIX] +config BR2_GNU_BUILD_SUFFIX + string "GNU build hostname suffix" + default "pc-linux-gnu" + help + The string used to pass to configure scripts via the + --build= option. Just specify the suffix here, the leading + arch will be filled in automatically. + + Here's some copy and paste build host options for you: + linux: pc-linux-gnu + cygwin: pc-cygwin + os x: apple-darwin7 / apple-darwin8 + config BR2_JLEVEL int "Number of jobs to run simultaneously" default "1" diff --git a/package/Makefile.in b/package/Makefile.in index 281680aa4..ce4fb28f5 100644 --- a/package/Makefile.in +++ b/package/Makefile.in @@ -65,7 +65,7 @@ HOST_ARCH:=$(shell $(HOSTCC) -dumpmachine | sed -e s'/-.*//' \ -e 's/cris.*/cris/' \ -e 's/i[3-9]86/i386/' \ ) -GNU_HOST_NAME:=$(HOST_ARCH)-pc-linux-gnu +GNU_HOST_NAME:=$(HOST_ARCH)-$(subst ",,$(BR2_GNU_BUILD_SUFFIX)) TARGET_CONFIGURE_OPTS=PATH=$(TARGET_PATH) \ AR=$(TARGET_CROSS)ar \ AS=$(TARGET_CROSS)as \ |