diff options
author | Gustavo Zacarias <gustavo@zacarias.com.ar> | 2010-05-06 11:24:36 -0300 |
---|---|---|
committer | Peter Korsgaard <jacmet@sunsite.dk> | 2010-05-06 23:07:21 +0200 |
commit | a5fe7371b28ed52a019dc424821f199d0f86b969 (patch) | |
tree | c76ee4e582172cefeebdf6e705eaacb90c004341 | |
parent | dfb503937df53cb1e43a33f264b561bc99acf6ff (diff) | |
download | buildroot-novena-a5fe7371b28ed52a019dc424821f199d0f86b969.tar.gz buildroot-novena-a5fe7371b28ed52a019dc424821f199d0f86b969.zip |
pciutils: Fix cross compiling
Closes #1705
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r-- | CHANGES | 3 | ||||
-rw-r--r-- | package/pciutils/Config.in | 3 | ||||
-rw-r--r-- | package/pciutils/pciutils.mk | 4 |
3 files changed, 9 insertions, 1 deletions
@@ -2,7 +2,7 @@ Fixes all over the tree. - Updated/fixed packages: hal, mplayer, + Updated/fixed packages: hal, mplayer, pciutils, xdriver_xf86-video-openchrome, usb_modeswitch, usbutils Issues resolved (http://bugs.uclibc.org): @@ -10,6 +10,7 @@ #985: Bump usb_modeswitch package to 1.1.0 #1525: Package hal deletes a whole <target>/etc/rc.d directory #1699: Fix usbutils dependencies and bump + #1705: Fix pciutils broken cross compiling 2010.05-rc1, Released May 3rd, 2010: diff --git a/package/pciutils/Config.in b/package/pciutils/Config.in index bc026602f..07fc49b82 100644 --- a/package/pciutils/Config.in +++ b/package/pciutils/Config.in @@ -7,4 +7,7 @@ config BR2_PACKAGE_PCIUTILS Various utilities dealing with the PCI bus. Provides things like setpci and lspci. + You'll need a copy of pci.ids or pci.ids.gz in your + target skeleton to enjoy verbose output. + http://atrey.karlin.mff.cuni.cz/~mj/pciutils.html diff --git a/package/pciutils/pciutils.mk b/package/pciutils/pciutils.mk index 393162f62..2b999dfb5 100644 --- a/package/pciutils/pciutils.mk +++ b/package/pciutils/pciutils.mk @@ -18,10 +18,12 @@ define PCIUTILS_CONFIGURE_CMDS $(SED) 's/uname -s/echo Linux/' \ -e 's/uname -r/echo $(LINUX_HEADERS_VERSION)/' \ $(PCIUTILS_DIR)/lib/configure + $(SED) 's/^STRIP/#STRIP/' $(PCIUTILS_DIR)/Makefile endef define PCIUTILS_BUILD_CMDS $(MAKE) CC="$(TARGET_CC)" \ + HOST="$(KERNEL_ARCH)-linux" \ OPT="$(TARGET_CFLAGS)" \ LDFLAGS="$(TARGET_LDFLAGS)" \ RANLIB=$(TARGET_RANLIB) \ @@ -33,8 +35,10 @@ define PCIUTILS_BUILD_CMDS SHAREDIR=/usr/share/misc endef +# Ditch install-lib if SHARED is an option in the future define PCIUTILS_INSTALL_TARGET_CMDS $(MAKE) BUILDDIR=$(@D) -C $(@D) PREFIX=$(TARGET_DIR)/usr install + $(MAKE) BUILDDIR=$(@D) -C $(@D) PREFIX=$(TARGET_DIR)/usr install-lib endef $(eval $(call GENTARGETS,package,pciutils)) |