diff options
author | Arnar Mar SigurĂ°sson <antab@valka.is> | 2008-06-01 17:58:48 +0000 |
---|---|---|
committer | Arnar Mar SigurĂ°sson <antab@valka.is> | 2008-06-01 17:58:48 +0000 |
commit | 65063afec93970406b8529371b0519e5d2a5062d (patch) | |
tree | 1e046bf57e5775181355e272c71cd0659ef10731 | |
parent | e7bdf94241b031ed1308a915e9a58b949d52f31f (diff) | |
download | buildroot-novena-65063afec93970406b8529371b0519e5d2a5062d.tar.gz buildroot-novena-65063afec93970406b8529371b0519e5d2a5062d.zip |
Add option to set default site to download package source from. FreeBSD ports mirrors (like: ftp2.uk.freebsd.org/pub/FreeBSD/ports/distfiles) are a good place to find almost all of the source packages.
-rw-r--r-- | Config.in | 9 | ||||
-rw-r--r-- | package/Makefile.autotools.in | 3 |
2 files changed, 12 insertions, 0 deletions
@@ -15,6 +15,15 @@ source "target/device/Config.in" menu "Build options" +config BR2_PRIMARY_SITE + string "Primary download site" + default "" + help + Primary site to download from. If this option is set then buildroot + will try to download package source first from this site and try the + default if the file is not found. + NOTE: This only works for packages using the Makefile.autotools.in + config BR2_WGET string "Wget command" default "wget --passive-ftp -nd" diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in index cf2ac7d23..09c30958c 100644 --- a/package/Makefile.autotools.in +++ b/package/Makefile.autotools.in @@ -131,6 +131,9 @@ TAR ?= tar # Retrieve and unpack the archive $(BUILD_DIR)/%/.stamp_downloaded: $(call MESSAGE,"Downloading") +ifdef BR2_PRIMARY_SITE + -$(Q)test -e $(DL_DIR)/$($(PKG)_SOURCE) || $(WGET) -P $(DL_DIR) $(BR2_PRIMARY_SITE)/$($(PKG)_SOURCE) +endif $(Q)test -e $(DL_DIR)/$($(PKG)_SOURCE) || $(WGET) -P $(DL_DIR) $($(PKG)_SITE)/$($(PKG)_SOURCE) $(if $($(PKG)_PATCH),$(Q)test -e $(DL_DIR)/$($(PKG)_PATCH) || $(WGET) -P $(DL_DIR) $($(PKG)_SITE)/$($(PKG)_PATCH)) $(Q)mkdir -p $(@D) |