diff options
author | Thomas Petazzoni <thomas.petazzoni@free-electrons.com> | 2011-09-29 21:57:38 +0200 |
---|---|---|
committer | Peter Korsgaard <jacmet@sunsite.dk> | 2011-09-29 22:19:08 +0200 |
commit | ee0246e1e1d83f41985489c85dfef07098a2026d (patch) | |
tree | 4f9c4ea6f5b8651b29b16ca30132a7a15af30fd2 | |
parent | da76f0f1558698dd398c74393afc35cebfcc7dc7 (diff) | |
download | buildroot-novena-ee0246e1e1d83f41985489c85dfef07098a2026d.tar.gz buildroot-novena-ee0246e1e1d83f41985489c85dfef07098a2026d.zip |
package: add configuration option to specify a local override file
The user can now create a custom local override file to override the
source directory for various packages.
An example override file:
ZLIB_OVERRIDE_SRCDIR = /tmp/zlib
STRACE_OVERRIDE_SRCDIR = /opt/strace-4.5.20
would tell Buildroot to use the zlib and strace source code from the
specified directories, instead of download, extracting and patching
the code has done usually by Buildroot.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r-- | Config.in | 10 | ||||
-rw-r--r-- | Makefile | 7 |
2 files changed, 17 insertions, 0 deletions
@@ -334,6 +334,16 @@ config BR2_HAVE_DEVFILES Install headers and static libraries in the target filesystem +config BR2_PACKAGE_OVERRIDE_FILE + string "location of a package override file" + default "$(TOPDIR)/local.mk" + help + A package override file is a short makefile that contains + variable definitions of the form <pkg>_OVERRIDE_SRCDIR, + which allows to tell Buildroot to use an existing directory + as the source directory for a particular package. See the + Buildroot documentation for more details on this feature. + endmenu source "toolchain/Config.in" @@ -309,6 +309,13 @@ else ifeq ($(BR2_TOOLCHAIN_CTNG),y) include toolchain/toolchain-crosstool-ng.mk endif +# Include the package override file if one has been provided in the +# configuration. +PACKAGE_OVERRIDE_FILE=$(call qstrip,$(BR2_PACKAGE_OVERRIDE_FILE)) +ifneq ($(PACKAGE_OVERRIDE_FILE),) +-include $(PACKAGE_OVERRIDE_FILE) +endif + include package/*/*.mk include boot/common.mk |