diff options
author | Damian Kaczmarek <damian@veritymedical.co.uk> | 2011-10-21 00:05:23 +0200 |
---|---|---|
committer | Peter Korsgaard <jacmet@sunsite.dk> | 2011-11-24 23:07:09 +0100 |
commit | 9f930d2d7f6ca80d9ccc9a38e631704c1b931f43 (patch) | |
tree | c11fb4ac80430564603a59d254124e26742a9aa7 | |
parent | 0ff53f128d865dacfd7a46a5ee9e36c2f28cd89f (diff) | |
download | buildroot-novena-9f930d2d7f6ca80d9ccc9a38e631704c1b931f43.tar.gz buildroot-novena-9f930d2d7f6ca80d9ccc9a38e631704c1b931f43.zip |
lsof: fix permission of extracted files
Closes #4369
Default tar permissiong make it impossible to apply patches to some of
the files.
Change extraction command to skip permissions by using "-O" tar option
and a pipe tar chain.
Solution suggested by: Arnout Vandecappelle <arnout@mind.be>
[Peter: rework to use define as suggested by Thomas]
Signed-off-by: Damian Kaczmarek <damian@veritymedical.co.uk>
Tested-by: "Yann E. MORIN" <yann.morin.1998@anciens.enib.fr>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r-- | CHANGES | 4 | ||||
-rw-r--r-- | package/lsof/lsof.mk | 9 |
2 files changed, 8 insertions, 5 deletions
@@ -9,6 +9,10 @@ Updated/fixed packages: busybox, freetype, mplayer, opencv, rsyslog, xapp_xf86dga + Issues resolved (http://bugs.uclibc.org): + + #4369: Fix permissions on untared lsof archive + 2011.11-rc2, Released November 18th, 2011: Fixes all over the tree and new features. diff --git a/package/lsof/lsof.mk b/package/lsof/lsof.mk index ff76f92c6..c07fb2da3 100644 --- a/package/lsof/lsof.mk +++ b/package/lsof/lsof.mk @@ -33,13 +33,12 @@ endef endif # The .tar.bz2 contains another .tar, which contains the source code. -define LSOF_EXTRACT_TAR - $(TAR) $(TAR_STRIP_COMPONENTS)=1 -xf $(@D)/lsof_$(LSOF_VERSION)_src.tar -C $(@D) - rm -f $(@D)/lsof_$(LSOF_VERSION)_src.tar +define LSOF_EXTRACT_CMDS + $(INFLATE.bz2) $(DL_DIR)/$(LSOF_SOURCE) | \ + $(TAR) -O $(TAR_OPTIONS) - lsof_$(LSOF_VERSION)/lsof_$(LSOF_VERSION)_src.tar | \ + $(TAR) $(TAR_STRIP_COMPONENTS)=1 -C $(LSOF_DIR) $(TAR_OPTIONS) - endef -LSOF_POST_EXTRACT_HOOKS += LSOF_EXTRACT_TAR - define LSOF_CONFIGURE_CMDS (cd $(@D) ; \ echo n | $(TARGET_CONFIGURE_OPTS) DEBUG="$(TARGET_CFLAGS) $(BR2_LSOF_CFLAGS)" \ |