diff options
author | Peter Korsgaard <jacmet@sunsite.dk> | 2009-11-22 21:03:42 +0100 |
---|---|---|
committer | Peter Korsgaard <jacmet@sunsite.dk> | 2009-11-22 21:03:42 +0100 |
commit | 351b679608e805ed1d6f27a1f6b5e2398eb3a5eb (patch) | |
tree | c8511a8e77a80adb06f59b7c1ca4cdebb58be278 | |
parent | 3445ff4adebd3674d8e227479800efe987682d07 (diff) | |
download | buildroot-novena-351b679608e805ed1d6f27a1f6b5e2398eb3a5eb.tar.gz buildroot-novena-351b679608e805ed1d6f27a1f6b5e2398eb3a5eb.zip |
package/sdl: fix dependencies for directfb/qt/x11 support
Closes #683
And cleanup Kconfig while we're at it.
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r-- | CHANGES | 9 | ||||
-rw-r--r-- | package/sdl/Config.in | 11 | ||||
-rw-r--r-- | package/sdl/sdl.mk | 5 |
3 files changed, 17 insertions, 8 deletions
@@ -15,10 +15,10 @@ gst-plugins-good, imagemagick, ipkg, iptables, iw, kernel-headers, kismet, libelf, libevent, libglib2, libidn, liblockfile, libmad, libpcap, libupnp, libuuid, lighttpd, ltrace, lua, lzma, mdadm, ncftp, - ncurses, netkittelnet, netsnmp, ntfs-3g, openntp, openssl, php, python, - quagga, radvd, rsync, samba, sawman, shared-mime-info, spawn-fcgi, - speech-tools, sqlite, squashfs, synergy, syslinux, tcpdump, u-boot, - util-linux, valgrind, vsftpd, wipe + ncurses, netkittelnet, netsnmp, ntfs-3g, openntp, openssl, php, + python, quagga, radvd, rsync, samba, sawman, sdl, shared-mime-info, + spawn-fcgi, speech-tools, sqlite, squashfs, synergy, syslinux, + tcpdump, u-boot, util-linux, valgrind, vsftpd, wipe wpa-supplicant, xdata_xcursor-themes, zlib @@ -44,6 +44,7 @@ #657: Bug in imagemagick-clean target #665: [PATCH] Samba package #667: [PATCH] e2fsprogs + #683: SDL-dfb does not select directfb #701: make install problem with unstripped binaries #703: [SECURITY] Update openssl package to 0.9.8l #705: Bump spawn-fcgi package to 1.6.3 diff --git a/package/sdl/Config.in b/package/sdl/Config.in index 7cba524f3..869173d88 100644 --- a/package/sdl/Config.in +++ b/package/sdl/Config.in @@ -1,11 +1,13 @@ config BR2_PACKAGE_SDL bool "SDL" help + Simple DirectMedia Layer - SDL is a library that allows + programs portable low level access to a video framebuffer, + audio output, mouse, and keyboard. http://www.libsdl.org/ -menu "SDL options selection" - depends on BR2_PACKAGE_SDL +if BR2_PACKAGE_SDL config BR2_PACKAGE_SDL_FBCON bool "SDL framebuffer console video driver" @@ -13,11 +15,14 @@ config BR2_PACKAGE_SDL_FBCON config BR2_PACKAGE_SDL_DIRECTFB bool "SDL DirectFB video driver" + depends on BR2_PACKAGE_DIRECTFB config BR2_PACKAGE_SDL_QTOPIA bool "SDL Qtopia video driver" + depends on BR2_PACKAGE_QT config BR2_PACKAGE_SDL_X11 bool "SDL X11 video driver" + depends on BR2_PACKAGE_XORG7 -endmenu +endif diff --git a/package/sdl/sdl.mk b/package/sdl/sdl.mk index e9d6c0cd0..f66ecc4f1 100644 --- a/package/sdl/sdl.mk +++ b/package/sdl/sdl.mk @@ -18,6 +18,7 @@ SDL_FBCON=--enable-video-fbcon=no endif ifeq ($(BR2_PACKAGE_SDL_DIRECTFB),y) +SDL_DEPENDENCIES += directfb SDL_DIRECTFB=--enable-video-directfb=yes SDL_DIRECTFB_TARGET:=$(STAGING_DIR)/include/directfb SDL_DIRECTFB_INCLUDES:=-I$(STAGING_DIR)/usr/include/directfb @@ -28,12 +29,14 @@ endif ifeq ($(BR2_PACKAGE_SDL_QTOPIA),y) SDL_QTOPIA=--enable-video-qtopia=yes +SDL_DEPENDENCIES += qt else SDL_QTOPIA=--enable-video-qtopia=no endif ifeq ($(BR2_PACKAGE_SDL_X11),y) SDL_X11=--enable-video-x11=yes +SDL_DEPENDENCIES += xserver_xorg-server else SDL_X11=--enable-video-x11=no endif @@ -96,7 +99,7 @@ $(TARGET_DIR)/usr/lib/libSDL.so: $(STAGING_DIR)/usr/lib/libSDL.so cp -dpf $(STAGING_DIR)/usr/lib/libSDL*.so* $(TARGET_DIR)/usr/lib/ -$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/lib/libSDL.so -SDL sdl: $(TARGET_DIR)/usr/lib/libSDL.so +SDL sdl: $(SDL_DEPENDENCIES) $(TARGET_DIR)/usr/lib/libSDL.so sdl-unpacked: $(SDL_DIR)/.unpacked |