diff options
author | Gustavo Zacarias <gustavo@zacarias.com.ar> | 2009-11-13 12:07:56 -0300 |
---|---|---|
committer | Peter Korsgaard <jacmet@sunsite.dk> | 2009-11-15 23:41:35 +0100 |
commit | 83f9881d64cd7bcd760bc935e992e95ef3136b93 (patch) | |
tree | f9f286920be6b984db84627a1261f40ae7369364 | |
parent | 26073d2aa7d6f0406a4df616993d58441a239c96 (diff) | |
download | buildroot-novena-83f9881d64cd7bcd760bc935e992e95ef3136b93.tar.gz buildroot-novena-83f9881d64cd7bcd760bc935e992e95ef3136b93.zip |
libidn: update to 1.15 and other fixes
Closes #715
* Add target uninstall.
* Remove stray /usr/share/emacs files.
* Remove stray mono (host, autodetected) dll installation in
$(TARGET_DIR)/usr/lib by disabling C# altogether.
* Disable java.
* Add new option to install idn binary (default N, usually not required).
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r-- | CHANGES | 5 | ||||
-rw-r--r-- | package/libidn/libidn.mk | 20 |
2 files changed, 20 insertions, 5 deletions
@@ -6,8 +6,8 @@ Updated/fixed packages: autoconf, busybox, gcc, directfb, dnsmasq, e2fsprogs, festival, gstreamer, gst-plugins-bad, gst-plugins-base, gst-plugins-good, imagemagick, iptables, kernel-headers, kismet, - libelf, libevent, libglib2, liblockfile, libmad, libpcap, libupnp, - libuuid, lighttpd, ltrace, lua, lzma, mdadm, ncftp, ncurses, + libelf, libevent, libglib2, libidn, liblockfile, libmad, libpcap, + libupnp, libuuid, lighttpd, ltrace, lua, lzma, mdadm, ncftp, ncurses, netkittelnet, netsnmp, ntfs-3g, openntp, openssl, php, python, quagga, radvd, rsync, samba, sawman, shared-mime-info, speech-tools, sqlite, squashfs, synergy, syslinux, tcpdump, u-boot, util-linux, @@ -39,6 +39,7 @@ #667: [PATCH] e2fsprogs #709: Bump lighttpd package to 1.4.24 #713: Migrate openntpd package to Makefile.autotools.in + #715: Bump libidn package to 1.15 and other fixes 2009.08, Released August 31th, 2009: diff --git a/package/libidn/libidn.mk b/package/libidn/libidn.mk index 50d9bebbf..52f59f23b 100644 --- a/package/libidn/libidn.mk +++ b/package/libidn/libidn.mk @@ -3,12 +3,26 @@ # libidn # ############################################################# -LIBIDN_VERSION = 1.9 -LIBIDN_SOURCE = libidn-$(LIBIDN_VERSION).tar.gz + +LIBIDN_VERSION = 1.15 LIBIDN_SITE = http://ftp.gnu.org/gnu/libidn/ LIBIDN_INSTALL_STAGING = YES LIBIDN_INSTALL_TARGET = YES -LIBIDN_CONF_OPT = --enable-shared +LIBIDN_CONF_OPT = --enable-shared --disable-java --enable-csharp=no +LIBIDN_LIBTOOL_PATCH = NO LIBIDN_DEPENDENCIES = host-pkgconfig gettext $(if $(BR2_PACKAGE_LIBICONV),libiconv) $(eval $(call AUTOTARGETS,package,libidn)) + +$(LIBIDN_HOOK_POST_INSTALL): +ifneq ($(BR2_PACKAGE_LIBIDN_BINARY),y) + rm -f $(TARGET_DIR)/usr/bin/idn +endif + rm -rf $(TARGET_DIR)/usr/share/emacs + touch $@ + +$(LIBIDN_TARGET_UNINSTALL): + $(call MESSAGE,"Uninstalling") + rm -f $(TARGET_DIR)/usr/lib/libidn* + rm -f $(TARGET_DIR)/usr/bin/idn + rm -f $(LIBIDN_TARGET_INSTALL_TARGET) $(LIBIDN_HOOK_POST_INSTALL) |