aboutsummaryrefslogtreecommitdiffstats
path: root/packages/dreamplug-uaputl/Makefile
diff options
context:
space:
mode:
authorJacob Appelbaum <jacob@appelbaum.net>2011-08-17 23:26:49 +0200
committerJacob Appelbaum <jacob@appelbaum.net>2011-08-17 23:26:49 +0200
commitdb825c5f289564a9753783e61c098589ba8a886b (patch)
treed31133457804501fcd4bcdee637fa56985adfe31 /packages/dreamplug-uaputl/Makefile
parent7b46a0af09791cbfcb723de44ccd7f0388bc34b1 (diff)
downloadtorouter-db825c5f289564a9753783e61c098589ba8a886b.tar.gz
torouter-db825c5f289564a9753783e61c098589ba8a886b.zip
add gpl2 uaputl srcs before use
Diffstat (limited to 'packages/dreamplug-uaputl/Makefile')
-rwxr-xr-xpackages/dreamplug-uaputl/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/packages/dreamplug-uaputl/Makefile b/packages/dreamplug-uaputl/Makefile
new file mode 100755
index 0000000..1847183
--- /dev/null
+++ b/packages/dreamplug-uaputl/Makefile
@@ -0,0 +1,52 @@
+# File : uaputl/Makefile
+#
+# Copyright (C) 2008, Marvell International Ltd.
+# All Rights Reserved
+
+# Path to the top directory of the wlan distribution
+PATH_TO_TOP = ../..
+
+# Determine how we should copy things to the install directory
+ABSPATH := $(filter /%, $(INSTALLDIR))
+RELPATH := $(filter-out /%, $(INSTALLDIR))
+INSTALLPATH := $(ABSPATH)
+ifeq ($(strip $(INSTALLPATH)),)
+INSTALLPATH := $(PATH_TO_TOP)/$(RELPATH)
+endif
+
+# Override CFLAGS for application sources, remove __ kernel namespace defines
+CFLAGS := $(filter-out -D__%, $(EXTRA_CFLAGS))
+
+
+#CFLAGS += -DAP22 -fshort-enums
+CFLAGS += -Wall
+#ECHO = @
+LIBS = -lrt
+
+.PHONY: default tags all
+
+OBJECTS = uaputl.o uapcmd.o
+HEADERS = uaputl.h uapcmd.h
+
+TARGET = uaputl
+
+build default: $(TARGET)
+ @cp -f $(TARGET) $(INSTALLPATH)
+ @cp -rf config/* $(INSTALLPATH)
+
+
+all : tags default
+
+$(TARGET): $(OBJECTS) $(HEADERS)
+ $(ECHO)$(CC) $(LIBS) -o $@ $(OBJECTS)
+
+%.o: %.c $(HEADERS)
+ $(ECHO)$(CC) $(CFLAGS) -c -o $@ $<
+
+tags:
+ ctags -R -f tags.txt
+
+clean:
+ $(ECHO)$(RM) $(OBJECTS) $(TARGET)
+ $(ECHO)$(RM) tags.txt
+