aboutsummaryrefslogtreecommitdiffstats
path: root/adenosine-pds/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'adenosine-pds/Cargo.toml')
-rw-r--r--adenosine-pds/Cargo.toml32
1 files changed, 12 insertions, 20 deletions
diff --git a/adenosine-pds/Cargo.toml b/adenosine-pds/Cargo.toml
index 41cfaae..f9dba1a 100644
--- a/adenosine-pds/Cargo.toml
+++ b/adenosine-pds/Cargo.toml
@@ -13,32 +13,24 @@ readme = "README.md"
repository = "https://gitlab.com/bnewbold/adenosine"
[dependencies]
+adenosine = { version = "0.2.0", path = "../adenosine" }
anyhow = "1"
-structopt = "0.3"
-serde = "1"
-serde_json = "1"
+askama = { version = "0.11", features = ["serde-json"] }
+bcrypt = "0.13"
+data-encoding = "2"
+dotenvy = "0.15"
+#ipfs-sqlite-block-store = "0.13"
+lazy_static = "1"
+libipld = { version = "0.14", features = ["dag-cbor", "derive"] }
log = "0.4"
pretty_env_logger = "0.4"
-libipld = "0.14"
-ipfs-sqlite-block-store = "0.13"
+rouille = "3"
rusqlite = { version = "0.26", features = ["bundled"] }
rusqlite_migration = "1"
-# NOTE: lexicon validation not implemented yet
-#jsonschema = "*"
-#schemafy = "*"
-rouille = "3"
-# NOTE: vendored for now
-#iroh-car = "*"
-adenosine = { version = "0.2.0", path = "../adenosine" }
+serde = "1"
+serde_json = "1"
+structopt = "0.3"
tokio = { version = "1", features = ["full"] }
-futures = "0.3"
-lazy_static = "1"
-bcrypt = "0.13"
-data-encoding = "2"
-# TODO: replace this with data-encoding or similar; this is only needed for ucan_p256 stuff
-async-trait = "0.1"
-dotenvy = "0.15"
-askama = { version = "0.11", features = ["serde-json"] }
[package.metadata.deb]
maintainer = "Bryan Newbold <bnewbold@robocracy.org>"