aboutsummaryrefslogtreecommitdiffstats
path: root/adenosine-common/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'adenosine-common/Cargo.toml')
-rw-r--r--adenosine-common/Cargo.toml23
1 files changed, 23 insertions, 0 deletions
diff --git a/adenosine-common/Cargo.toml b/adenosine-common/Cargo.toml
new file mode 100644
index 0000000..f6f1ad2
--- /dev/null
+++ b/adenosine-common/Cargo.toml
@@ -0,0 +1,23 @@
+[package]
+name = "adenosine-common"
+description = "Shared things (eg, types) for adenosine codebase"
+keywords = ["atproto"]
+categories = []
+
+# common across workspace
+version = "0.1.0-dev.0"
+edition = "2021"
+rust-version = "1.61"
+authors = ["Bryan Newbold <bnewbold@robocracy.org>"]
+license = "AGPLv3"
+readme = "../README.md"
+repository = "https://gitlab.com/bnewbold/adenosine"
+
+[dependencies]
+structopt = "*"
+regex = "*"
+lazy_static = "*"
+data-encoding = "*"
+rand = "*"
+anyhow = "1.0"
+