aboutsummaryrefslogtreecommitdiffstats
path: root/iroh-car/Cargo.toml
diff options
context:
space:
mode:
authorBryan Newbold <bnewbold@robocracy.org>2022-10-28 20:00:55 -0700
committerBryan Newbold <bnewbold@robocracy.org>2022-10-28 20:00:55 -0700
commitf99cff96758176701656285712246173db76ac58 (patch)
tree10a4f8c167c055b39a96a342f9a9334ec877414e /iroh-car/Cargo.toml
parent4b4eb3aa819ee16cd8d7074cfd21d94deab2276d (diff)
downloadadenosine-f99cff96758176701656285712246173db76ac58.tar.gz
adenosine-f99cff96758176701656285712246173db76ac58.zip
copy in iroh-car from iroh repo, verbatim
Diffstat (limited to 'iroh-car/Cargo.toml')
-rw-r--r--iroh-car/Cargo.toml23
1 files changed, 23 insertions, 0 deletions
diff --git a/iroh-car/Cargo.toml b/iroh-car/Cargo.toml
new file mode 100644
index 0000000..3130af1
--- /dev/null
+++ b/iroh-car/Cargo.toml
@@ -0,0 +1,23 @@
+[package]
+name = "iroh-car"
+version = "0.1.0"
+edition = "2021"
+authors = ["Friedel Ziegelmayer <me@dignifiedquire.com>"]
+license = "Apache-2.0/MIT"
+repository = "https://github.com/n0-computer/iroh"
+description = "Implementation the car files for iroh"
+
+[dependencies]
+cid = "0.8"
+ipld = { package = "libipld", version = "0.14"}
+ipld-cbor = { package = "libipld-cbor", version = "0.14" }
+thiserror = "1.0"
+futures = "0.3.21"
+integer-encoding = { version = "3.0", features = ["tokio_async"] }
+multihash = "0.16"
+tokio = { version = "1", features = ["io-util"] }
+
+[dev-dependencies]
+tokio = { version = "1", features = ["macros", "sync", "rt", "fs", "io-util"] }
+
+[features]