aboutsummaryrefslogtreecommitdiffstats
path: root/iroh-car/Cargo.toml
diff options
context:
space:
mode:
authorBryan Newbold <bnewbold@robocracy.org>2022-10-28 20:04:13 -0700
committerBryan Newbold <bnewbold@robocracy.org>2022-10-28 20:04:13 -0700
commitc86ae10560bdafbfc06fc9fac50626630cf6a8a4 (patch)
treec29af8c90182a34b681993af95fcede0599e5e66 /iroh-car/Cargo.toml
parentf99cff96758176701656285712246173db76ac58 (diff)
downloadadenosine-c86ae10560bdafbfc06fc9fac50626630cf6a8a4.tar.gz
adenosine-c86ae10560bdafbfc06fc9fac50626630cf6a8a4.zip
cargo: add iroh-car to workspace; tweak deps to reduce duplication
Diffstat (limited to 'iroh-car/Cargo.toml')
-rw-r--r--iroh-car/Cargo.toml8
1 files changed, 4 insertions, 4 deletions
diff --git a/iroh-car/Cargo.toml b/iroh-car/Cargo.toml
index 3130af1..64fc6f0 100644
--- a/iroh-car/Cargo.toml
+++ b/iroh-car/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "iroh-car"
-version = "0.1.0"
+version = "0.1.0-vendored.0"
edition = "2021"
authors = ["Friedel Ziegelmayer <me@dignifiedquire.com>"]
license = "Apache-2.0/MIT"
@@ -8,12 +8,12 @@ repository = "https://github.com/n0-computer/iroh"
description = "Implementation the car files for iroh"
[dependencies]
-cid = "0.8"
+cid = "*"
ipld = { package = "libipld", version = "0.14"}
ipld-cbor = { package = "libipld-cbor", version = "0.14" }
thiserror = "1.0"
-futures = "0.3.21"
-integer-encoding = { version = "3.0", features = ["tokio_async"] }
+futures = "0.3"
+integer-encoding = { version = "3", features = ["tokio_async"] }
multihash = "0.16"
tokio = { version = "1", features = ["io-util"] }