summaryrefslogtreecommitdiffstats
path: root/adenosine-pds/Cargo.toml
diff options
context:
space:
mode:
authorBryan Newbold <bnewbold@robocracy.org>2022-10-26 20:36:03 -0700
committerBryan Newbold <bnewbold@robocracy.org>2022-10-26 20:36:03 -0700
commitbab98346caeda7faa6fd7ce9f2dc5eadb828bc63 (patch)
tree66c03a25a847350f6976007a860f2070f98c7443 /adenosine-pds/Cargo.toml
parentc4485e4b134d946227d6cbd52f57ce175387749d (diff)
downloadadenosine-bab98346caeda7faa6fd7ce9f2dc5eadb828bc63.tar.gz
adenosine-bab98346caeda7faa6fd7ce9f2dc5eadb828bc63.zip
rename main crate to '-pds', start '-cli' crate
Diffstat (limited to 'adenosine-pds/Cargo.toml')
-rw-r--r--adenosine-pds/Cargo.toml30
1 files changed, 30 insertions, 0 deletions
diff --git a/adenosine-pds/Cargo.toml b/adenosine-pds/Cargo.toml
new file mode 100644
index 0000000..a3bb880
--- /dev/null
+++ b/adenosine-pds/Cargo.toml
@@ -0,0 +1,30 @@
+[package]
+name = "adenosine-pds"
+version = "0.1.0-dev.0"
+edition = "2021"
+authors = ["Bryan Newbold <bnewbold@robocracy.org>"]
+license = "AGPLv3"
+description = "Informal implementation of atproto.com"
+readme = "../README.md"
+repository = "https://gitlab.com/bnewbold/adenosine"
+keywords = ["atproto"]
+#categories = []
+
+[dependencies]
+structopt = "*"
+hyper = "*"
+tokio = { version = "1", features = ["full"] }
+serde_json = "*"
+log = "*"
+env_logger = "*"
+
+[package.metadata.deb]
+maintainer = "Bryan Newbold <bnewbold@robocracy.org>"
+depends = "$auto"
+section = "utility"
+priority = "optional"
+extended-description = """"TODO"""
+assets = [
+ ["target/release/adenosine-pds", "usr/bin/", "755"],
+ #["../extra/adenosine-pds.1", "usr/share/man/man1/", "644"],
+]