summaryrefslogtreecommitdiffstats
path: root/adenosine-cli/Cargo.toml
diff options
context:
space:
mode:
authorBryan Newbold <bnewbold@robocracy.org>2022-11-06 20:48:42 -0800
committerBryan Newbold <bnewbold@robocracy.org>2022-11-06 20:52:30 -0800
commit2641389cb74939df9090a8183ec67ab0558f0b06 (patch)
tree5be1764c3d6924db8f832887cf5019b75d39b571 /adenosine-cli/Cargo.toml
parent2a7771915e7547baefb48975507536a1c69b986b (diff)
downloadadenosine-2641389cb74939df9090a8183ec67ab0558f0b06.tar.gz
adenosine-2641389cb74939df9090a8183ec67ab0558f0b06.zip
cli: switch identifiers to adenosine-common
Diffstat (limited to 'adenosine-cli/Cargo.toml')
-rw-r--r--adenosine-cli/Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/adenosine-cli/Cargo.toml b/adenosine-cli/Cargo.toml
index 4f9bc6d..7b2902a 100644
--- a/adenosine-cli/Cargo.toml
+++ b/adenosine-cli/Cargo.toml
@@ -15,6 +15,7 @@ readme = "../README.md"
repository = "https://gitlab.com/bnewbold/adenosine"
[dependencies]
+adenosine-common = { version = "0.1.0-dev.0", path = "../adenosine-common" }
structopt = "*"
# NOTE: could try 'rustls-tls' feature instead of default native TLS?
reqwest = { version = "0.11", features = ["blocking", "json"] }
@@ -39,7 +40,7 @@ maintainer = "Bryan Newbold <bnewbold@robocracy.org>"
depends = "$auto"
section = "utility"
priority = "optional"
-extended-description = """"TODO"""
+extended-description = """"This is a simple, enthusiast-grade CLI client for the work-in-progress AT Protocol (atproto.com). It is an entirely \"delegated\" client, which means that it does not store or cache any user content locally; everything works by making HTTP/XRPC requests to a Personal Data Server (PDS), which is usually a remote service."""
assets = [
["target/release/adenosine", "usr/bin/", "755"],
["../extra/adenosine.1", "usr/share/man/man1/", "644"],