aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml24
1 files changed, 16 insertions, 8 deletions
diff --git a/Cargo.toml b/Cargo.toml
index edec13a..18e7e0a 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "glutin"
-version = "0.1.6"
+version = "0.2.2"
authors = ["tomaka <pierre.krieger1708@gmail.com>"]
description = "Cross-plaform OpenGL context provider."
keywords = ["windowing", "opengl"]
@@ -22,7 +22,7 @@ shared_library = "0.1.0"
[build-dependencies]
gl_generator = "0.0.26"
-khronos_api = "0.0.5"
+khronos_api = "0.0.6"
[dev-dependencies]
clock_ticks = "0.0.5"
@@ -44,6 +44,7 @@ objc = "0.1"
[target.x86_64-apple-darwin.dependencies]
objc = "0.1"
+cgl = "0"
cocoa = "0"
core-foundation = "0"
core-graphics = "0"
@@ -62,20 +63,27 @@ user32-sys = "~0.1.1"
kernel32-sys = "0.1"
dwmapi-sys = "0.1"
+[target.x86_64-pc-windows-msvc.dependencies]
+winapi = "~0.1.18"
+gdi32-sys = "0.1"
+user32-sys = "~0.1.1"
+kernel32-sys = "0.1"
+dwmapi-sys = "0.1"
+
[target.i686-unknown-linux-gnu.dependencies]
osmesa-sys = "0.0.5"
-wayland-client = "0.1.6"
-wayland-kbd = "0.1.1"
+wayland-client = { version = "0.2.0", features = ["egl", "dlopen"] }
+wayland-kbd = "0.2.0"
x11-dl = "=1.0.1"
[target.x86_64-unknown-linux-gnu.dependencies]
osmesa-sys = "0.0.5"
-wayland-client = "0.1.6"
-wayland-kbd = "0.1.1"
+wayland-client = { version = "0.2.0", features = ["egl", "dlopen"] }
+wayland-kbd = "0.2.0"
x11-dl = "=1.0.1"
[target.arm-unknown-linux-gnueabihf.dependencies]
osmesa-sys = "0.0.5"
-wayland-client = "0.1.6"
-wayland-kbd = "0.1.1"
+wayland-client = { version = "0.2.0", features = ["egl", "dlopen"] }
+wayland-kbd = "0.2.0"
x11-dl = "=1.0.1"