aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml37
1 files changed, 18 insertions, 19 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a282b60..f1434d1 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -16,33 +16,32 @@ libc = "0.2"
shared_library = "0.1.0"
[build-dependencies]
-gl_generator = "0.4"
-khronos_api = "1.0"
+gl_generator = "0.5"
[target.arm-linux-androideabi.dependencies.android_glue]
version = "0.1"
[target.i386-apple-ios.dependencies]
-objc = "0.1.8"
+objc = "0.2"
[target.x86_64-apple-ios.dependencies]
-objc = "0.1.8"
+objc = "0.2"
[target.aarch64-apple-ios.dependencies]
-objc = "0.1.8"
+objc = "0.2"
[target.armv7s-apple-ios.dependencies]
-objc = "0.1.8"
+objc = "0.2"
[target.armv7-apple-ios.dependencies]
-objc = "0.1.8"
+objc = "0.2"
[target.x86_64-apple-darwin.dependencies]
-objc = "0.1.8"
+objc = "0.2"
cgl = "0.1"
-cocoa = "0.2.4"
+cocoa = "0.3"
core-foundation = "0"
-core-graphics = "0"
+core-graphics = "0.3"
[target.i686-pc-windows-gnu.dependencies]
winapi = "0.2"
@@ -81,60 +80,60 @@ osmesa-sys = "0.0.5"
wayland-client = { version = "0.5.4", features = ["egl", "dlopen"] }
wayland-kbd = "0.3.3"
wayland-window = "0.2.2"
-x11-dl = "~2.3"
+x11-dl = "~2.4"
[target.i586-unknown-linux-gnu.dependencies]
osmesa-sys = "0.0.5"
wayland-client = { version = "0.5.4", features = ["egl", "dlopen"] }
wayland-kbd = "0.3.3"
wayland-window = "0.2.2"
-x11-dl = "~2.3"
+x11-dl = "~2.4"
[target.x86_64-unknown-linux-gnu.dependencies]
osmesa-sys = "0.0.5"
wayland-client = { version = "0.5.4", features = ["egl", "dlopen"] }
wayland-kbd = "0.3.3"
wayland-window = "0.2.2"
-x11-dl = "~2.3"
+x11-dl = "~2.4"
[target.arm-unknown-linux-gnueabihf.dependencies]
osmesa-sys = "0.0.5"
wayland-client = { version = "0.5.4", features = ["egl", "dlopen"] }
wayland-kbd = "0.3.3"
wayland-window = "0.2.2"
-x11-dl = "~2.3"
+x11-dl = "~2.4"
[target.armv7-unknown-linux-gnueabihf.dependencies]
osmesa-sys = "0.0.5"
wayland-client = { version = "0.5.4", features = ["egl", "dlopen"] }
wayland-kbd = "0.3.3"
wayland-window = "0.2.2"
-x11-dl = "~2.3"
+x11-dl = "~2.4"
[target.aarch64-unknown-linux-gnu.dependencies]
osmesa-sys = "0.0.5"
wayland-client = { version = "0.5.4", features = ["egl", "dlopen"] }
wayland-kbd = "0.3.3"
wayland-window = "0.2.2"
-x11-dl = "~2.3"
+x11-dl = "~2.4"
[target.x86_64-unknown-dragonfly.dependencies]
osmesa-sys = "0.0.5"
wayland-client = { version = "0.5.4", features = ["egl", "dlopen"] }
wayland-kbd = "0.3.3"
wayland-window = "0.2.2"
-x11-dl = "~2.3"
+x11-dl = "~2.4"
[target.x86_64-unknown-freebsd.dependencies]
osmesa-sys = "0.0.5"
wayland-client = { version = "0.5.4", features = ["egl", "dlopen"] }
wayland-kbd = "0.3.3"
wayland-window = "0.2.2"
-x11-dl = "~2.3"
+x11-dl = "~2.4"
[target.x86_64-unknown-openbsd.dependencies]
osmesa-sys = "0.0.5"
wayland-client = { version = "0.5.4", features = ["egl", "dlopen"] }
wayland-kbd = "0.3.3"
wayland-window = "0.2.2"
-x11-dl = "~2.3"
+x11-dl = "~2.4"