aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml15
1 files changed, 12 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index f14ea8d..593a4a8 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -51,13 +51,22 @@ kernel32-sys = "0.1"
[target.i686-unknown-linux-gnu.dependencies]
osmesa-sys = "0.0.5"
wayland-client = "*"
-x11 = "*"
+
+[target.i686-unknown-linux-gnu.dependencies.x11]
+version = "*"
+features = ["dynamic"]
[target.x86_64-unknown-linux-gnu.dependencies]
osmesa-sys = "0.0.5"
wayland-client = "*"
-x11 = "*"
+
+[target.x86_64-unknown-linux-gnu.dependencies.x11]
+version = "*"
+features = ["dynamic"]
[target.arm-unknown-linux-gnueabihf.dependencies]
osmesa-sys = "0.0.5"
-x11 = "*"
+
+[target.arm-unknown-linux-gnueabihf.dependencies.x11]
+version = "*"
+features = ["dynamic"]