aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml20
1 files changed, 17 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a952eea..a74d1d5 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,13 +1,13 @@
[package]
name = "glutin"
-version = "0.3.5"
+version = "0.3.6"
authors = ["tomaka <pierre.krieger1708@gmail.com>"]
description = "Cross-plaform OpenGL context provider."
keywords = ["windowing", "opengl"]
license = "Apache-2.0"
readme = "README.md"
repository = "https://github.com/tomaka/glutin"
-documentation = "http://tomaka.github.io/glutin/"
+documentation = "https://tomaka.github.io/glutin/"
build = "build.rs"
[features]
@@ -21,7 +21,7 @@ libc = "0.1"
shared_library = "0.1.0"
[build-dependencies]
-gl_generator = "0.0.26"
+gl_generator = "0.0.27"
khronos_api = "0.0.7"
[dev-dependencies]
@@ -108,3 +108,17 @@ wayland-client = { version = "0.2.1", features = ["egl", "dlopen"] }
wayland-kbd = "0.2.0"
wayland-window = "0.1.0"
x11-dl = "~2.0"
+
+[target.x86_64-unknown-dragonfly.dependencies]
+osmesa-sys = "0.0.5"
+wayland-client = { version = "0.2.1", features = ["egl", "dlopen"] }
+wayland-kbd = "0.2.0"
+wayland-window = "0.1.0"
+x11-dl = "~2.0"
+
+[target.x86_64-unknown-freebsd.dependencies]
+osmesa-sys = "0.0.5"
+wayland-client = { version = "0.2.1", features = ["egl", "dlopen"] }
+wayland-kbd = "0.2.0"
+wayland-window = "0.1.0"
+x11-dl = "~2.0"