aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMichael Neumann <mneumann@ntecs.de>2015-08-29 22:54:17 +0200
committerMichael Neumann <mneumann@ntecs.de>2015-08-30 13:52:09 +0200
commitb707959c2c0ae97c2225c2e6dbc07fc754125458 (patch)
treebd9b70c965bd0edbf2a96c1be7ecc4c440488c87 /Cargo.toml
parentb8b1b80631e1335a7ab747f34e1c67dfa0790a10 (diff)
downloadglutin-b707959c2c0ae97c2225c2e6dbc07fc754125458.tar.gz
glutin-b707959c2c0ae97c2225c2e6dbc07fc754125458.zip
Make it work on DragonFly/FreeBSD
Tested on DragonFly BSD. Should work similarily on FreeBSD.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml14
1 files changed, 14 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a952eea..5662754 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -108,3 +108,17 @@ wayland-client = { version = "0.2.1", features = ["egl", "dlopen"] }
wayland-kbd = "0.2.0"
wayland-window = "0.1.0"
x11-dl = "~2.0"
+
+[target.x86_64-unknown-dragonfly.dependencies]
+osmesa-sys = "0.0.5"
+wayland-client = { version = "0.2.1", features = ["egl", "dlopen"] }
+wayland-kbd = "0.2.0"
+wayland-window = "0.1.0"
+x11-dl = "~2.0"
+
+[target.x86_64-unknown-freebsd.dependencies]
+osmesa-sys = "0.0.5"
+wayland-client = { version = "0.2.1", features = ["egl", "dlopen"] }
+wayland-kbd = "0.2.0"
+wayland-window = "0.1.0"
+x11-dl = "~2.0"