aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorKirill Zdornyy <kirill@dineserve.com>2016-03-01 18:06:13 -0800
committerKirill Zdornyy <kirill@dineserve.com>2016-03-01 18:06:13 -0800
commit74a28adba2a07d56bce9592f24196442192e68e0 (patch)
treed1d0075f4e4f60015c021da70b6eabf67313f37d /Cargo.toml
parent366608d026b7bcdb2b7478e932b0776ad0b51531 (diff)
downloadglutin-74a28adba2a07d56bce9592f24196442192e68e0.tar.gz
glutin-74a28adba2a07d56bce9592f24196442192e68e0.zip
Fix this_platform_is_not_supported on OpenBSD.
I followed the steps of @mneumann.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 7 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 4f53c3b..a282b60 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -131,3 +131,10 @@ wayland-client = { version = "0.5.4", features = ["egl", "dlopen"] }
wayland-kbd = "0.3.3"
wayland-window = "0.2.2"
x11-dl = "~2.3"
+
+[target.x86_64-unknown-openbsd.dependencies]
+osmesa-sys = "0.0.5"
+wayland-client = { version = "0.5.4", features = ["egl", "dlopen"] }
+wayland-kbd = "0.3.3"
+wayland-window = "0.2.2"
+x11-dl = "~2.3"