aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authormitchmindtree <mitchell.nordine@gmail.com>2015-11-08 21:13:25 +1100
committermitchmindtree <mitchell.nordine@gmail.com>2015-11-08 21:13:25 +1100
commit228732877a6c64f2d923d04bd6ed4c771289ecdf (patch)
treef9af35754d0204bbe7284ea798201cd88b5bc5e0 /Cargo.toml
parent0386d093d1acca9c6010e6360bef781726efde5c (diff)
downloadglutin-228732877a6c64f2d923d04bd6ed4c771289ecdf.tar.gz
glutin-228732877a6c64f2d923d04bd6ed4c771289ecdf.zip
Lock objc version, add casts to appease libc pointer type conflict. Closes #654
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml14
1 files changed, 7 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 5cccfe1..5ee7201 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -27,23 +27,23 @@ clock_ticks = "0.1.0"
version = "0.1"
[target.i386-apple-ios.dependencies]
-objc = "0.1"
+objc = ">=0.1.0, <=0.1.7"
[target.x86_64-apple-ios.dependencies]
-objc = "0.1"
+objc = ">=0.1.0, <=0.1.7"
[target.aarch64-apple-ios.dependencies]
-objc = "0.1"
+objc = ">=0.1.0, <=0.1.7"
[target.armv7s-apple-ios.dependencies]
-objc = "0.1"
+objc = ">=0.1.0, <=0.1.7"
[target.armv7-apple-ios.dependencies]
-objc = "0.1"
+objc = ">=0.1.0, <=0.1.7"
[target.x86_64-apple-darwin.dependencies]
-objc = "0.1"
-cgl = "0"
+objc = ">=0.1.0, <=0.1.7"
+cgl = "0.1"
cocoa = "0.1.4"
core-foundation = "0"
core-graphics = "0"