aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/modules/sound.mk36
1 files changed, 21 insertions, 15 deletions
diff --git a/package/kernel/modules/sound.mk b/package/kernel/modules/sound.mk
index 4ccdc8b80..3d12ba650 100644
--- a/package/kernel/modules/sound.mk
+++ b/package/kernel/modules/sound.mk
@@ -7,21 +7,6 @@
SOUND_MENU:=Sound Support
-define KernelPackage/pcspkr
- SUBMENU:=$(SOUND_MENU)
- TITLE:=PC speaker support
- KCONFIG:=CONFIG_INPUT_PCSPKR
- FILES:=$(LINUX_DIR)/drivers/input/misc/pcspkr.ko
- AUTOLOAD:=$(call AutoLoad,50,pcspkr)
-endef
-
-define KernelPackage/pcspkr/description
- This enables sounds (tones) through the pc speaker
-endef
-
-$(eval $(call KernelPackage,pcspkr))
-
-
# allow targets to override the soundcore stuff
SOUNDCORE_LOAD ?= \
soundcore \
@@ -201,3 +186,24 @@ define KernelPackage/sound-soc-gw_avila
endef
$(eval $(call KernelPackage,sound-soc-gw_avila))
+
+
+define KernelPackage/pcspkr
+ DEPENDS:=@!TARGET_x86
+ TITLE:=PC speaker support
+ KCONFIG:= \
+ CONFIG_INPUT_PCSPKR \
+ CONFIG_SND_PCSP
+ FILES:= \
+ $(LINUX_DIR)/drivers/input/misc/pcspkr.ko \
+ $(LINUX_DIR)/sound/drivers/pcsp/snd-pcsp.ko
+ AUTOLOAD:=$(call AutoLoad,50,pcspkr snd-pcsp)
+ $(call AddDepends/input)
+ $(call AddDepends/sound)
+endef
+
+define KernelPackage/pcspkr/description
+ This enables sounds (tones) through the pc speaker
+endef
+
+$(eval $(call KernelPackage,pcspkr))