aboutsummaryrefslogtreecommitdiffstats
path: root/tools/sdcc/Makefile
diff options
context:
space:
mode:
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-05 10:12:53 +0000
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-10-05 10:12:53 +0000
commit5c105d9f3fd086aff195d3849dcf847d6b0bd927 (patch)
tree1229a11f725bfa58aa7c57a76898553bb5f6654a /tools/sdcc/Makefile
downloadopenwrt-5c105d9f3fd086aff195d3849dcf847d6b0bd927.tar.gz
openwrt-5c105d9f3fd086aff195d3849dcf847d6b0bd927.zip
branch Attitude Adjustment
git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@33625 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/sdcc/Makefile')
-rw-r--r--tools/sdcc/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/tools/sdcc/Makefile b/tools/sdcc/Makefile
new file mode 100644
index 000000000..3210bb3e7
--- /dev/null
+++ b/tools/sdcc/Makefile
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=sdcc
+PKG_VERSION:=3.0.0
+
+PKG_SOURCE:=$(PKG_NAME)-src-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
+PKG_MD5SUM:=20fbd49a3421e09fe65577c45524c89e
+
+HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_LDFLAGS += $(HOST_STATIC_LINKING)
+HOST_CONFIGURE_ARGS += \
+ --disable-ucsim \
+ --enable-packihx \
+ --enable-sdcpp \
+ --disable-sdcdb \
+ --disable-gbz80-port \
+ --disable-z80-port \
+ --disable-ds390-port \
+ --disable-ds400-port \
+ --disable-pic-port \
+ --disable-pic16-port \
+ --disable-hc08-port \
+ --disable-avr-port \
+ --disable-xa51-port \
+ --enable-mcs51-port \
+ --enable-device-lib \
+
+define Host/Clean
+ -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+ $(call Host/Clean/Default)
+endef
+
+$(eval $(call HostBuild))