aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-11-29 17:49:50 +0000
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-11-29 17:49:50 +0000
commit518938eefbfdca419c31b711257b4c397ebb8556 (patch)
treedf417aa470efd3a1afea60af18b12e90c62ff620
parentc1646179c70c96832acaa021a1dea9ecce0ad08f (diff)
downloadopenwrt-518938eefbfdca419c31b711257b4c397ebb8556.tar.gz
openwrt-518938eefbfdca419c31b711257b4c397ebb8556.zip
AA: build: Add TARGET_ROOTFS_RESERVED_PCT option to reduce wasted space
Backport of r34408. The genext2fs tool will 'reserve' 5% of the image size by default, apparently by creating a huge lost+found directory. In fact it seemed to be much more than 5% in practice — I saw an image with 8MiB used, and recovered about 2MiB of it by deleting the 'empty' lost+found directory: /dev/loop0 48377 8482 37438 19% /mnt/spare # rmdir lost+found/ /dev/loop0 48377 6014 39906 14% /mnt/spare This makes it configurable, but leaves it at the genext2fs default of 5% for now. It should probably be changed to default to zero, but that can be a separate patch. Signed-off-by: David Woodhouse <David.Woodhouse@intel.com> Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@34412 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--Config.in7
-rw-r--r--include/image.mk2
2 files changed, 8 insertions, 1 deletions
diff --git a/Config.in b/Config.in
index bd4f63ea4..19c8edfb9 100644
--- a/Config.in
+++ b/Config.in
@@ -124,6 +124,13 @@ menu "Target Images"
help
Allows you to change the maximum number of inodes in the root filesystem
+ config TARGET_ROOTFS_RESERVED_PCT
+ int "Percentage of reserved blocks in root filesystem"
+ depends TARGET_ROOTFS_EXT4FS
+ default 5
+ help
+ Allows you to change the percentage of reserved blocks in the root filesystem
+
endmenu
menu "Global build settings"
diff --git a/include/image.mk b/include/image.mk
index 1977fc84c..f0d2ee664 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -124,7 +124,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_EXT4FS),)
define Image/mkfs/ext4
# generate an ext2 fs
- $(STAGING_DIR_HOST)/bin/genext2fs -U -b $(E2SIZE) -N $(CONFIG_TARGET_ROOTFS_MAXINODE) -d $(TARGET_DIR)/ $(KDIR)/root.ext4
+ $(STAGING_DIR_HOST)/bin/genext2fs -U -b $(E2SIZE) -N $(CONFIG_TARGET_ROOTFS_MAXINODE) -d $(TARGET_DIR)/ $(KDIR)/root.ext4 -m $(CONFIG_TARGET_ROOTFS_RESERVED_PCT)
# convert it to ext4
$(STAGING_DIR_HOST)/bin/tune2fs -O extents,uninit_bg,dir_index $(KDIR)/root.ext4
# fix it up