aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml11
1 files changed, 1 insertions, 10 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 57aa54b..cd16e93 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -2,19 +2,14 @@
name = "modelthing"
version = "0.1.0"
authors = ["bnewbold <bnewbold@robocracy.org>"]
-build = "src/build.rs" # eg, LALRPOP preprocessing
-
-[build-dependencies]
-lalrpop = "0.12"
[dependencies]
getopts = "^0.2"
toml = "0.2"
log = "0.3"
env_logger = "0.3"
-lalrpop-util = "^0.12.4"
markdown = "0.1"
-colored = "1.3"
+modelica-parser-lalrpop = { version = "*", path = "./modelica-parser-lalrpop" }
# parser util
rustc-serialize = "0.3"
@@ -23,7 +18,3 @@ docopt = "0.6"
# webface
pencil = "0.3"
-
-[features]
-# this effectively enables the feature `no-color` of colored when testing
-test = ["colored/no-color"]