aboutsummaryrefslogtreecommitdiffstats
path: root/slib.spec
diff options
context:
space:
mode:
Diffstat (limited to 'slib.spec')
-rw-r--r--slib.spec37
1 files changed, 16 insertions, 21 deletions
diff --git a/slib.spec b/slib.spec
index 38e425a..4ed4bcd 100644
--- a/slib.spec
+++ b/slib.spec
@@ -1,5 +1,5 @@
%define name slib
-%define version 2d2
+%define version 3a1
%define release 1
Name: %{name}
@@ -55,32 +55,27 @@ if [ -L /usr/share/guile/slib ]; then
ln -s %{prefix}/slib /usr/share/guile/slib
fi
-# This section should be extended to rebuild catalogs for as many
-# implementations as possible.
-if type guile; then
- guile -c "(use-modules (ice-9 slib)) (require 'new-catalog)"
-fi
-if type scm; then
- scm -c "(require 'new-catalog)"
-fi
-if type umb-scheme; then
- SCHEME_INIT=${SCHEME_LIBRARY_PATH}umbscheme.init
- echo "(require 'new-catalog)" | umb-scheme
-fi
-if type mzscheme; then
- SCHEME_LIBRARY_PATH=`pwd`/
- rm /usr/local/lib/plt-103/slibcat
- mzscheme -L init.ss slibinit -e "(require 'new-catalog)"
-fi
-if type scheme48; then
- make install48
-fi
+# Rebuild catalogs for as many implementations as possible.
+export PATH=$PATH:/usr/local/bin
+echo PATH=${PATH}
+cd %{prefix}/slib/
+make catalogs
+# Make color-name databases.
+make clrnamdb
+
+%preun
+cd %{prefix}/slib/
+rm -f clrnamdb.scm srcdir.mk slib.image
%files
%defattr(-, root, root)
%dir %{prefix}/slib
%{prefix}/slib/*.scm
%{prefix}/slib/*.init
+%{prefix}/slib/cie1931.xyz
+%{prefix}/slib/cie1964.xyz
+%{prefix}/slib/saturate.txt
+%{prefix}/slib/resenecolours.txt
/usr/info/slib.info.gz
# The Makefile is included as it is useful for building documentation.
%{prefix}/slib/Makefile