aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog30
-rw-r--r--debian/control14
-rw-r--r--debian/copyright30
-rw-r--r--debian/postinst7
-rw-r--r--debian/postrm4
-rwxr-xr-xdebian/rules93
-rw-r--r--debian/slibconfig7
7 files changed, 185 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..a91b6e1
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,30 @@
+slib (2c0-3) unstable; urgency=low
+
+ * New maintainer.
+ * slibconfig script to automatically configure guile.
+ * Fix type in description, closes: Bug#18996
+
+ -- Jim Pick <jim@jimpick.com> Sun, 8 Mar 1998 23:05:22 -0800
+
+slib (2c0-2) unstable; urgency=low
+
+ * Minor fix for debian/rules targets
+
+ -- Rob Browning <rlb@cs.utexas.edu> Fri, 12 Dec 1997 17:35:22 -0600
+
+slib (2c0-1) unstable; urgency=low
+
+ * New upstream source
+ * New maintainer
+
+ -- Rob Browning <rlb@cs.utexas.edu> Fri, 12 Dec 1997 16:49:13 -0600
+
+slib (2a6-1) unstable; urgency=low
+
+ * First Debian release.
+
+ -- Karl Sackett <krs@debian.org> Mon, 16 Dec 1996 09:23:46 -0600
+
+Local variables:
+mode: debian-changelog
+End:
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..b71a19b
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,14 @@
+Source: slib
+Section: devel
+Priority: optional
+Maintainer: Jim Pick <jim@jimpick.com>
+Standards-Version: 2.1.1.2
+
+Package: slib
+Architecture: all
+Description: Portable Scheme library.
+ SLIB is a portable scheme library meant to provide compatibility and
+ utility functions for all standard scheme implementations. SLIB
+ includes initialization files for Chez, ELK 2.1, GAMBIT, MacScheme,
+ MITScheme, scheme->C, Scheme48, T3.1, and VSCM. SCM also supports
+ SLIB.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..65247b2
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,30 @@
+This is the Debian GNU/Linux prepackaged version of slib.
+
+This package was put together by Rob Browning <rlb@cs.utexas.edu>
+from sources obtained from:
+
+ ftp://swiss-ftp.ai.mit.edu/archive/scm/slib2c0.tar.gz
+
+For more information see:
+
+ http://www-swiss.ai.mit.edu/~jaffer/SLIB.html
+
+The source files are all subject to the following copyright:
+
+; Copyright (C) 1991, 1992, 1993, 1994, 1997 Aubrey Jaffer.
+;
+;Permission to copy this software, to redistribute it, and to use it
+;for any purpose is granted, subject to the following restrictions and
+;understandings.
+;
+;1. Any copy made of this software must include this copyright notice
+;in full.
+;
+;2. I have made no warrantee or representation that the operation of
+;this software will be error-free, and I am under no obligation to
+;provide any services, by way of maintenance, update, or otherwise.
+;
+;3. In conjunction with products arising from the use of this
+;material, there shall be no use of my name in any advertising,
+;promotional, or sales literature without prior written consent in
+;each case.
diff --git a/debian/postinst b/debian/postinst
new file mode 100644
index 0000000..a00d1a5
--- /dev/null
+++ b/debian/postinst
@@ -0,0 +1,7 @@
+#!/bin/sh
+set -e
+
+install-info --quiet --section "Development" "Development" \
+ --description="The SLIB portable Scheme library" \
+ /usr/info/slib.info.gz
+/usr/sbin/slibconfig
diff --git a/debian/postrm b/debian/postrm
new file mode 100644
index 0000000..03e39ad
--- /dev/null
+++ b/debian/postrm
@@ -0,0 +1,4 @@
+#!/bin/sh
+set -e
+
+install-info --quiet --remove slib
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..e76c9fb
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,93 @@
+#! /usr/bin/make -f
+# -*-Makefile-*-
+
+CC =gcc
+CFLAGS =-O2 -g -Wall
+LDFLAGS =
+
+SHELL =/bin/sh
+srcdir =.
+
+INSTALL =/usr/bin/install
+INSTALL_DIR =$(INSTALL) -d -m 755 -o root -g root
+INSTALL_PROGRAM =$(INSTALL) -m 755 -o root -g root
+INSTALL_DATA =$(INSTALL) -m 644 -o root -g root
+INSTALL_MAN =$(INSTALL) -m 444 -o root -g root
+
+build:
+ $(checkdir)
+ make
+ texi2html -monolithic slib.texi
+ touch build
+
+clean:
+ $(checkdir)
+ -rm slib.html
+ -rm slib.info*
+ make clean
+ -rm -f build
+ -rm -rf debian/tmp* *~ debian/*~ debian/files debian/substvars
+
+binary-arch: checkroot
+ $(checkdir)
+
+binary-indep: checkroot build
+ $(checkdir)
+ -rm -rf debian/tmp*
+
+# debian/tmp
+ $(INSTALL_DIR) debian/tmp
+ $(INSTALL_DIR) debian/tmp/DEBIAN
+ $(INSTALL_PROGRAM) debian/postinst debian/tmp/DEBIAN
+ $(INSTALL_PROGRAM) debian/postrm debian/tmp/DEBIAN
+
+# library
+ $(INSTALL_DIR) debian/tmp/usr/lib/slib
+ $(INSTALL_DATA) *.scm debian/tmp/usr/lib/slib
+
+# documentation
+ $(INSTALL_DIR) debian/tmp/usr/doc/slib
+ $(INSTALL_DATA) debian/copyright debian/tmp/usr/doc/slib
+ $(INSTALL_DATA) debian/changelog \
+ debian/tmp/usr/doc/slib/changelog.Debian
+ gzip -9v debian/tmp/usr/doc/slib/changelog.Debian
+
+ $(INSTALL_DATA) ChangeLog debian/tmp/usr/doc/slib
+ gzip -9v debian/tmp/usr/doc/slib/ChangeLog
+ $(INSTALL_DATA) README debian/tmp/usr/doc/slib
+ gzip -9v debian/tmp/usr/doc/slib/README
+ $(INSTALL_DATA) FAQ debian/tmp/usr/doc/slib
+ gzip -9v debian/tmp/usr/doc/slib/FAQ
+ $(INSTALL_DATA) slib.html debian/tmp/usr/doc/slib
+
+ $(INSTALL_DIR) debian/tmp/usr/lib/slib/init
+ $(INSTALL_DATA) *.init debian/tmp/usr/lib/slib/init
+
+# info pages
+ $(INSTALL_DIR) debian/tmp/usr/info
+ $(INSTALL_DATA) slib.info* debian/tmp/usr/info
+ gzip -9v debian/tmp/usr/info/*
+
+# slibconfig
+
+ $(INSTALL_DIR) debian/tmp/usr/sbin
+ $(INSTALL_PROGRAM) debian/slibconfig debian/tmp/usr/sbin
+ $(INSTALL_DIR) debian/tmp/usr/man/man8
+ (cd debian/tmp/usr/man/man8; \
+ ln -s ../man7/undocumented.7.gz slibconfig.8.gz \
+ )
+
+ dpkg-gencontrol
+ dpkg --build debian/tmp ..
+
+define checkdir
+ test -f slib.texi -a -f debian/rules
+endef
+
+binary: binary-indep binary-arch
+
+checkroot:
+ $(checkdir)
+ test root = "`whoami`"
+
+.PHONY: config build clean binary binary-arch binary-indep
diff --git a/debian/slibconfig b/debian/slibconfig
new file mode 100644
index 0000000..05eee30
--- /dev/null
+++ b/debian/slibconfig
@@ -0,0 +1,7 @@
+#! /bin/sh
+
+if [ -d /usr/share/guile -a -x /usr/bin/guile ]; then
+ (cd /usr/share/guile
+ guile -c "(use-modules (ice-9 slib)) (require 'new-catalog)"
+ )
+fi