aboutsummaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/712322_fix_doc_build.patch121
-rw-r--r--debian/patches/712322_use_local_schmooz.patch8
-rw-r--r--debian/patches/debian-changes.patch (renamed from debian/patches/debian-changes-3b1-3.1)81
-rw-r--r--debian/patches/do-not-regenerate-version-txi.patch16
-rw-r--r--debian/patches/series3
5 files changed, 88 insertions, 141 deletions
diff --git a/debian/patches/712322_fix_doc_build.patch b/debian/patches/712322_fix_doc_build.patch
index f2b4985..5abe34d 100644
--- a/debian/patches/712322_fix_doc_build.patch
+++ b/debian/patches/712322_fix_doc_build.patch
@@ -5,11 +5,8 @@ Description: Fix texinfo files for texinfo 5
Bug-Debian: http://bugs.debian.org/712322
Forwarded: not-needed
-
-Index: slib/phil-spc.scm
-===================================================================
---- slib.orig/phil-spc.scm
-+++ slib/phil-spc.scm
+--- a/phil-spc.scm
++++ b/phil-spc.scm
@@ -136,8 +136,9 @@
;;@defun integer->gray-code k
;;Converts @var{k} to a Gray code of the same @code{integer-length} as
@@ -21,11 +18,9 @@ Index: slib/phil-spc.scm
;;Converts the Gray code @var{k} to an integer of the same
;;@code{integer-length} as @var{k}.
;;
-Index: slib/schmooz.texi
-===================================================================
---- slib.orig/schmooz.texi
-+++ slib/schmooz.texi
-@@ -17,8 +17,9 @@ existing file containing Scheme source c
+--- a/schmooz.texi
++++ b/schmooz.texi
+@@ -17,8 +17,9 @@
top-level comments containing schmooz commands from @var{filename}.scm
and writes the converted Texinfo source to a file named
@var{filename}.txi.
@@ -36,11 +31,9 @@ Index: slib/schmooz.texi
@deffnx Procedure schmooz filename@r{.tex} @dots{}
@deffnx Procedure schmooz filename@r{.txi} @dots{}
@var{Filename} should be a string naming an existing file containing
-Index: slib/slib.texi
-===================================================================
---- slib.orig/slib.texi
-+++ slib/slib.texi
-@@ -816,11 +816,13 @@ and the name of the operating system. A
+--- a/slib.texi
++++ b/slib.texi
+@@ -816,11 +816,13 @@
Displays the information of @code{(slib:report-version)} followed by
almost all the information neccessary for submitting a problem report.
An unspecified value is returned.
@@ -56,7 +49,7 @@ Index: slib/slib.texi
Writes the report to file @file{filename}.
@example
-@@ -944,8 +946,9 @@ omitted, in which case it defaults to th
+@@ -944,8 +946,9 @@
current position of the character in @var{port} which will next be
read or written. If the implementation does not support
file-position, then @code{#f} is returned.
@@ -67,7 +60,7 @@ Index: slib/slib.texi
@var{port} must be open to a file. @code{file-position} sets the
current position in @var{port} which will next be read or written. If
successful, @code{#f} is returned; otherwise @code{file-position}
-@@ -3390,7 +3393,7 @@ non-numeric conversions.
+@@ -3390,7 +3393,7 @@
A character that specifies the conversion to be applied.
@end itemize
@@ -76,7 +69,7 @@ Index: slib/slib.texi
@table @asis
@item @samp{b}, @samp{B}
-@@ -3416,7 +3419,7 @@ using the digits @samp{0123456789abcdef}
+@@ -3416,7 +3419,7 @@
digits @samp{0123456789ABCDEF}.
@end table
@@ -85,7 +78,7 @@ Index: slib/slib.texi
@table @asis
@item @samp{f}
-@@ -3441,7 +3444,8 @@ dot between number and prefix, @samp{%k}
+@@ -3441,7 +3444,8 @@
@end table
@@ -95,7 +88,7 @@ Index: slib/slib.texi
@table @asis
@item @samp{c}
Print a single character. The @samp{-} flag is the only one which can
-@@ -4582,11 +4586,13 @@ compatability. Because of shared state
+@@ -4582,11 +4586,13 @@
@defun tzset
Returns the default time-zone.
@@ -111,7 +104,7 @@ Index: slib/slib.texi
Sets (and returns) the default time-zone to that specified by
@var{TZ-string}.
-@@ -4660,11 +4666,13 @@ is a datatype encapsulating time.
+@@ -4660,11 +4666,13 @@
@defun gmtime caltime
Converts the calendar time @var{caltime} to UTC and returns it.
@@ -127,7 +120,7 @@ Index: slib/slib.texi
converts the calendar time @var{caltime} to a vector of integers
expressed relative to the user's time zone. @code{localtime} sets the
variable @var{*timezone*} with the difference between Coordinated
-@@ -4676,12 +4684,14 @@ Universal Time (UTC) and local standard
+@@ -4676,12 +4684,14 @@
@defun gmktime univtime
Converts a vector of integers in GMT Coordinated Universal Time (UTC)
format to a calendar time.
@@ -144,7 +137,7 @@ Index: slib/slib.texi
Converts a vector of integers in Coordinated Universal Time (UTC) format
(relative to time-zone @var{tz})
to calendar time.
-@@ -5085,8 +5095,9 @@ reversed.
+@@ -5085,8 +5095,9 @@
@code{integer->list} returns a list of @var{len} booleans corresponding
to each bit of the given integer. #t is coded for each 1; #f for 0.
The @var{len} argument defaults to @code{(integer-length @var{k})}.
@@ -155,7 +148,7 @@ Index: slib/slib.texi
@code{list->integer} returns an integer formed from the booleans in the
list @var{list}, which must be a list of booleans. A 1 bit is coded for
each #t; a 0 bit for #f.
-@@ -5508,8 +5519,9 @@ Computes the P1003.2/D11.2 (POSIX.2) 32-
+@@ -5508,8 +5519,9 @@
(cksum (in-vicinity (library-vicinity) "ratize.scm"))
@result{} 157103930
@end example
@@ -166,7 +159,7 @@ Index: slib/slib.texi
Computes the checksum of the bytes read from @var{port} until the
end-of-file.
-@@ -5528,8 +5540,9 @@ checksum of the bytes in @var{str}, can
+@@ -5528,8 +5540,9 @@
@defun crc16 file
Computes the USB data-packet (16-bit) CRC of @var{file}.
@@ -177,7 +170,7 @@ Index: slib/slib.texi
Computes the USB data-packet (16-bit) CRC of the bytes read from
@var{port} until the end-of-file.
-@@ -5541,8 +5554,9 @@ in http://www.usb.org/developers/data/cr
+@@ -5541,8 +5554,9 @@
@defun crc5 file
Computes the USB token (5-bit) CRC of @var{file}.
@@ -188,7 +181,7 @@ Index: slib/slib.texi
Computes the USB token (5-bit) CRC of the bytes read from
@var{port} until the end-of-file.
-@@ -5736,8 +5750,9 @@ encountered in practice and the literatu
+@@ -5736,8 +5750,9 @@
@defun color? obj
Returns #t if @var{obj} is a color.
@@ -199,7 +192,7 @@ Index: slib/slib.texi
Returns #t if @var{obj} is a color of color-space @var{typ}. The symbol
@var{typ} must be one of:
-@@ -5950,14 +5965,16 @@ values.
+@@ -5950,14 +5965,16 @@
Loads the Spectral Tristimulus Values
@cite{CIE 1964 Supplementary Standard Colorimetric Observer},
defining @var{cie:x-bar}, @var{cie:y-bar}, and @var{cie:z-bar}.
@@ -218,7 +211,7 @@ Index: slib/slib.texi
@ftindex ciexyz
Requires Spectral Tristimulus Values, defaulting to cie1931,
defining @var{cie:x-bar}, @var{cie:y-bar}, and @var{cie:z-bar}.
-@@ -6026,8 +6043,9 @@ result of applying @var{proc} to each el
+@@ -6026,8 +6043,9 @@
computes the CIEXYZ(1931) values for the spectrum returned by @var{proc}
when called with arguments from 380e-9 to 780e-9, the wavelength in
meters.
@@ -229,7 +222,7 @@ Index: slib/slib.texi
@var{x1} and @var{x2} must be positive real numbers specifying the
wavelengths (in meters) corresponding to the zeroth and last elements of
vector or list @var{spectrum}. @code{spectrum->XYZ} returns the
-@@ -6149,8 +6167,9 @@ Returns a three element list: the @var{x
+@@ -6149,8 +6167,9 @@
scales each chromaticity so it sums to 1 or less; and divides the
@var{Y} values by the maximum @var{Y} in the dataset, so all lie between
0 and 1.
@@ -240,7 +233,7 @@ Index: slib/slib.texi
If @var{n} is positive real, then @code{xyY:normalize-colors} divides
the @var{Y} values by @var{n} times the maximum @var{Y} in the dataset.
-@@ -6195,8 +6214,9 @@ color2 in the function entries.
+@@ -6195,8 +6214,9 @@
@defun L*a*b*:DE* lab1 lab2
Returns the Euclidean distance between @var{lab1} and @var{lab2}.
@@ -251,7 +244,7 @@ Index: slib/slib.texi
@defunx CIE:DE* color1 color2
Returns the Euclidean distance in L*a*b* space between @var{color1} and
@var{color2}.
-@@ -6708,8 +6728,9 @@ Defines a rule for the case when the ope
+@@ -6708,8 +6728,9 @@
@var{sub-op2}, respectively. The argument @var{reduction} is a
procedure accepting 2 arguments which will be lists whose @code{car}s
are @var{sub-op1} and @var{sub-op2}.
@@ -262,7 +255,7 @@ Index: slib/slib.texi
Defines a rule for the case when the operation represented by symbol
@var{op} is applied to a list whose @code{car} is @var{sub-op1}, and
some other argument. @var{Reduction} will be called with the list whose
-@@ -7195,8 +7216,9 @@ Returns a procedure of arguments @var{ke
+@@ -7195,8 +7216,9 @@
returns the key-list identifying the lowest record higher than
@var{key1} @var{key2} @dots{} which is stored in the relational-table;
or false if no higher record is present.
@@ -273,7 +266,7 @@ Index: slib/slib.texi
The symbol @var{column-name} names a key field. In the list returned
by @code{isam-next}, that field, or a field to its left, will be
changed. This allows one to skip over less significant key fields.
-@@ -7207,8 +7229,9 @@ Returns a procedure of arguments @var{ke
+@@ -7207,8 +7229,9 @@
returns the key-list identifying the highest record less than
@var{key1} @var{key2} @dots{} which is stored in the relational-table;
or false if no lower record is present.
@@ -284,7 +277,7 @@ Index: slib/slib.texi
The symbol @var{column-name} names a key field. In the list returned
by @code{isam-next}, that field, or a field to its left, will be
changed. This allows one to skip over less significant key fields.
-@@ -7248,8 +7271,9 @@ Return a list of the column names, forei
+@@ -7248,8 +7271,9 @@
names, or type names respectively for this table. These 4 methods are
different from the others in that the list is returned, rather than a
procedure to obtain the list.
@@ -295,7 +288,7 @@ Index: slib/slib.texi
Returns the number of primary keys fields in the relations in this
table.
@end defop
-@@ -7382,16 +7406,19 @@ Returns an open enhanced relational data
+@@ -7382,16 +7406,19 @@
supplied, @code{open-command-database} will attempt to deduce the correct
base-table-type. If the database can not be opened or if it lacks the
@code{*commands*} table, @code{#f} is returned.
@@ -318,7 +311,7 @@ Index: slib/slib.texi
Returns @var{database} if it is a mutable relational database; #f
otherwise.
@end defun
-@@ -7912,32 +7939,31 @@ without-documentation called
+@@ -7912,32 +7939,31 @@
Prints the names of all the tables in @var{database} and sets browse's
default to @var{database}.
@@ -361,7 +354,7 @@ Index: slib/slib.texi
@end deffn
-@@ -8560,8 +8586,9 @@ Returns a methods procedure for a new (o
+@@ -8560,8 +8586,9 @@
describing the columns of a new base table in this database, otherwise
returns @code{#f}. For the fields and layout of descriptor tables,
@xref{Catalog Representation}.
@@ -372,7 +365,7 @@ Index: slib/slib.texi
Returns a methods procedure for a new (open) relational table with
columns as described by @var{table-desc-name}, otherwise returns
@code{#f}.
-@@ -9829,14 +9856,16 @@ Example:
+@@ -9829,14 +9856,16 @@
@defun list-of?? predicate
Returns a predicate which returns true if its argument is a list every
element of which satisfies @var{predicate}.
@@ -391,7 +384,7 @@ Index: slib/slib.texi
@var{bound} is an integer. If @var{bound} is negative, @code{list-of??}
returns a predicate which returns true if its argument is a list of
length greater than @code{(- @var{bound})}; every element of which
-@@ -10613,16 +10642,19 @@ character of the first substring of @var
+@@ -10613,16 +10642,19 @@
@deffn {Procedure} find-string-from-port? str in-port max-no-chars
Looks for a string @var{str} within the first @var{max-no-chars} chars
of the input port @var{in-port}.
@@ -414,7 +407,7 @@ Index: slib/slib.texi
Searches up to the first occurrence of the procedure @var{proc}
returning non-false when called with a character (from @var{in-port})
argument.
-@@ -11562,12 +11594,14 @@ printer for @code{qp}. This example sho
+@@ -11562,12 +11594,14 @@
@deffn {Procedure} trace-all file @dots{}
Traces (@pxref{Trace}) all procedures @code{define}d at top-level in
@file{file} @dots{}.
@@ -431,7 +424,7 @@ Index: slib/slib.texi
Stacks (@pxref{Trace}) all procedures @code{define}d at top-level in
@file{file} @dots{}.
@end deffn
-@@ -11603,8 +11637,9 @@ which it was called on a continuation st
+@@ -11603,8 +11637,9 @@
@defun continue
Pops the topmost continuation off of the continuation stack and returns
an unspecified value to it.
@@ -442,7 +435,7 @@ Index: slib/slib.texi
Pops the topmost continuation off of the continuation stack and returns
@var{arg1} @dots{} to it.
@end defun
-@@ -11612,7 +11647,9 @@ Pops the topmost continuation off of the
+@@ -11612,7 +11647,9 @@
@defmac break proc1 @dots{}
Redefines the top-level named procedures given as arguments so that
@code{breakpoint} is called before calling @var{proc1} @dots{}.
@@ -453,7 +446,7 @@ Index: slib/slib.texi
With no arguments, makes sure that all the currently broken identifiers
are broken (even if those identifiers have been redefined) and returns a
list of the broken identifiers.
-@@ -11620,7 +11657,9 @@ list of the broken identifiers.
+@@ -11620,7 +11657,9 @@
@defmac unbreak proc1 @dots{}
Turns breakpoints off for its arguments.
@@ -464,7 +457,7 @@ Index: slib/slib.texi
With no arguments, unbreaks all currently broken identifiers and returns
a list of these formerly broken identifiers.
@end defmac
-@@ -11695,7 +11734,9 @@ Prints the call-stack to @var{port} or t
+@@ -11695,7 +11734,9 @@
@defmac trace proc1 @dots{}
Traces the top-level named procedures given as arguments.
@@ -475,7 +468,7 @@ Index: slib/slib.texi
With no arguments, makes sure that all the currently traced identifiers
are traced (even if those identifiers have been redefined) and returns a
list of the traced identifiers.
-@@ -11703,7 +11744,8 @@ list of the traced identifiers.
+@@ -11703,7 +11744,8 @@
@defmac track proc1 @dots{}
Traces the top-level named procedures given as arguments.
@@ -485,7 +478,7 @@ Index: slib/slib.texi
With no arguments, makes sure that all the currently tracked identifiers
are tracked (even if those identifiers have been redefined) and returns
a list of the tracked identifiers.
-@@ -11711,7 +11753,8 @@ a list of the tracked identifiers.
+@@ -11711,7 +11753,8 @@
@defmac stack proc1 @dots{}
Traces the top-level named procedures given as arguments.
@@ -495,7 +488,7 @@ Index: slib/slib.texi
With no arguments, makes sure that all the currently stacked identifiers
are stacked (even if those identifiers have been redefined) and returns
a list of the stacked identifiers.
-@@ -11719,21 +11762,24 @@ a list of the stacked identifiers.
+@@ -11719,21 +11762,24 @@
@defmac untrace proc1 @dots{}
Turns tracing, tracking, and off for its arguments.
@@ -523,11 +516,9 @@ Index: slib/slib.texi
With no arguments, unstacks all currently stacked identifiers and returns
a list of these formerly stacked identifiers.
@end defmac
-Index: slib/color.txi
-===================================================================
---- slib.orig/color.txi
-+++ slib/color.txi
-@@ -107,8 +107,9 @@ then @code{l*a*b*->color} returns the co
+--- a/color.txi
++++ b/color.txi
+@@ -107,8 +107,9 @@
@defun color:l*a*b* L* a* b* white-point
Returns the L*a*b* color composed of @var{L*}, @var{a*}, @var{b*} with @var{white-point}.
@@ -538,7 +529,7 @@ Index: slib/color.txi
Returns the L*a*b* color composed of @var{L*}, @var{a*}, @var{b*}. If the coordinates
do not encode a valid L*a*b* color, then an error is signaled.
@end defun
-@@ -117,8 +118,9 @@ do not encode a valid L*a*b* color, then
+@@ -117,8 +118,9 @@
@defun color->l*a*b* color white-point
Returns the list of 3 numbers encoding @var{color} in L*a*b* with @var{white-point}.
@@ -549,7 +540,7 @@ Index: slib/color.txi
Returns the list of 3 numbers encoding @var{color} in L*a*b*.
@end defun
-@@ -138,8 +140,9 @@ then @code{l*u*v*->color} returns the co
+@@ -138,8 +140,9 @@
@defun color:l*u*v* L* u* v* white-point
Returns the L*u*v* color composed of @var{L*}, @var{u*}, @var{v*} with @var{white-point}.
@@ -560,7 +551,7 @@ Index: slib/color.txi
Returns the L*u*v* color composed of @var{L*}, @var{u*}, @var{v*}. If the coordinates
do not encode a valid L*u*v* color, then an error is signaled.
@end defun
-@@ -148,8 +151,9 @@ do not encode a valid L*u*v* color, then
+@@ -148,8 +151,9 @@
@defun color->l*u*v* color white-point
Returns the list of 3 numbers encoding @var{color} in L*u*v* with @var{white-point}.
@@ -571,7 +562,7 @@ Index: slib/color.txi
Returns the list of 3 numbers encoding @var{color} in L*u*v*.
@end defun
-@@ -206,8 +210,9 @@ then @code{l*c*h->color} returns the col
+@@ -206,8 +210,9 @@
@defun color:l*c*h L* C* h white-point
Returns the L*C*h color composed of @var{L*}, @var{C*}, @var{h} with @var{white-point}.
@@ -582,7 +573,7 @@ Index: slib/color.txi
Returns the L*C*h color composed of @var{L*}, @var{C*}, @var{h}. If the coordinates
do not encode a valid L*C*h color, then an error is signaled.
@end defun
-@@ -216,8 +221,9 @@ do not encode a valid L*C*h color, then
+@@ -216,8 +221,9 @@
@defun color->l*c*h color white-point
Returns the list of 3 numbers encoding @var{color} in L*C*h with @var{white-point}.
@@ -593,7 +584,7 @@ Index: slib/color.txi
Returns the list of 3 numbers encoding @var{color} in L*C*h.
@end defun
-@@ -326,11 +332,13 @@ specified by @var{rgb}; otherwise return
+@@ -326,11 +332,13 @@
@defun color:e-srgb 10 r g b
Returns the e-sRGB10 color composed of integers @var{r}, @var{g}, @var{b}.
@@ -609,10 +600,8 @@ Index: slib/color.txi
Returns the e-sRGB16 color composed of integers @var{r}, @var{g}, @var{b}.
If the coordinates do not encode a valid e-sRGB color, then an error
is signaled.
-Index: slib/schmooz.scm
-===================================================================
---- slib.orig/schmooz.scm
-+++ slib/schmooz.scm
+--- a/schmooz.scm
++++ b/schmooz.scm
@@ -306,22 +306,32 @@
#\!))
'("deffn {Procedure}" "deffnx {Procedure}" "deffn")
@@ -661,10 +650,8 @@ Index: slib/schmooz.scm
(out 0 "@end defvar")
(out 0)))
-Index: slib/grapheps.scm
-===================================================================
---- slib.orig/grapheps.scm
-+++ slib/grapheps.scm
+--- a/grapheps.scm
++++ b/grapheps.scm
@@ -527,12 +527,12 @@
;;over the range @2 to @3. If the optional integer argument @4 is
;;supplied, it specifies the number of points to evaluate @1 at.
diff --git a/debian/patches/712322_use_local_schmooz.patch b/debian/patches/712322_use_local_schmooz.patch
index 54a32b7..1b36006 100644
--- a/debian/patches/712322_use_local_schmooz.patch
+++ b/debian/patches/712322_use_local_schmooz.patch
@@ -6,11 +6,9 @@ Author: Ivo De Decker <ivodd@debian.org>
Bug-Debian: http://bugs.debian.org/712322
Forwarded: not-needed
-Index: slib/Makefile
-===================================================================
---- slib.orig/Makefile
-+++ slib/Makefile
-@@ -222,7 +222,7 @@ collectx.scm: collect.scm macwork.scm co
+--- a/Makefile
++++ b/Makefile
+@@ -222,7 +222,7 @@
$(scheme) < collect.sc
$(txifiles): $(txiscms) schmooz.scm
diff --git a/debian/patches/debian-changes-3b1-3.1 b/debian/patches/debian-changes.patch
index 27c64a7..8a08766 100644
--- a/debian/patches/debian-changes-3b1-3.1
+++ b/debian/patches/debian-changes.patch
@@ -1,63 +1,8 @@
-Description: Upstream changes introduced in version 3b1-3.1
- This patch has been created by dpkg-source during the package build.
- Here's the last changelog entry, hopefully it gives details on why
- those changes were made:
- .
- slib (3b1-3.1) unstable; urgency=low
- .
- [ Jari Aalto ]
- * Non-maintainer upload.
- - Move to packaging format "3.0 (quilt)".
- * debian/compat
- - Update to 7.
- * debian/control
- - (Build-Depends-Indep): Update to debhelper 7.1.
- - (Depends): add ${misc:Depends}.
- - (Homepage): New field.
- - (Standards-Version): update to 3.8.4.
- + slib
- - (Depends): add ${misc:Depends}, install-info.
- - (Priority): remove inherited field.
- - (Section): remove inherited field.
- * debian/copyright
- - Update "more information" URL.
- * debian/doc-base
- - (Section): Remove obsolete top-level "Apps/".
- * debian/prerm
- - Remove path component from commands.
- - Remove obsolete install-docs, install-info commands.
- * debian/postinst
- - Remove obsolete install-docs, install-info commands.
- - Remove path component from commands.
- * debian/source/format
- - New file.
- * debian/watch
- - New file.
- .
- [ Hideki Yamane (Debian-JP) <henrich@debian.or.jp> ]
- * debian/rules
- - (build): Rewrite make calls.
- - (binary-indep:): install *.html not slib/*.html to fix. It is
- useless to specify htmllib (FTBFS; Closes: #552911).
- .
- The person named in the Author field signed this changelog entry.
+Description: Upstream changes before switch to "3.0 (quilt)" source format in version 3b1-3.1
Author: Jari Aalto <jari.aalto@cante.net>
-Bug-Debian: http://bugs.debian.org/552911
----
-The information above should follow the Patch Tagging Guidelines, please
-checkout http://dep.debian.net/deps/dep3/ to learn about the format. Here
-are templates for supplementary fields that you might want to add:
-
-Origin: <vendor|upstream|other>, <url of original patch>
-Bug: <url in upstream bugtracker>
-Bug-Debian: http://bugs.debian.org/<bugnumber>
-Forwarded: <no|not-needed|url proving that it has been forwarded>
-Reviewed-By: <name and email of someone who approved the patch>
-Last-Update: <YYYY-MM-DD>
-
---- slib-3b1.orig/slib.1
-+++ slib-3b1/slib.1
+--- a/slib.1
++++ b/slib.1
@@ -1,5 +1,5 @@
.\" dummy line
-.TH SLIB "Dec 20 2007"
@@ -65,17 +10,17 @@ Last-Update: <YYYY-MM-DD>
.UC 4
.SH NAME
SLIB \- Scheme Library
---- slib-3b1.orig/slib.sh
-+++ slib-3b1/slib.sh
+--- a/slib.sh
++++ b/slib.sh
@@ -1,4 +1,4 @@
-
+#!/bin/bash
##"slib" script; Find a Scheme implementation and initialize SLIB in it.
#Copyright (C) 2003, 2004 Aubrey Jaffer
#
---- slib-3b1.orig/slib.texi
-+++ slib-3b1/slib.texi
-@@ -335,6 +335,12 @@ appropriate for the implementation.
+--- a/slib.texi
++++ b/slib.texi
+@@ -335,6 +335,12 @@
@code{macro:load}s the Scheme source file @i{<path>}.
@end table
@@ -88,9 +33,9 @@ Last-Update: <YYYY-MM-DD>
@node Catalog Creation, Catalog Vicinities, Library Catalogs, The Library System
@section Catalog Creation
---- slib-3b1.orig/Makefile
-+++ slib-3b1/Makefile
-@@ -239,14 +239,14 @@ xpdf: $(htmldir)slib.pdf
+--- a/Makefile
++++ b/Makefile
+@@ -239,14 +239,14 @@
xpdf $(htmldir)slib.pdf
TEXI2HTML = /usr/local/bin/texi2html -split -verbose
@@ -111,8 +56,8 @@ Last-Update: <YYYY-MM-DD>
slib-$(VERSION).info: version.txi slib.texi $(txifiles) $(texifiles)
makeinfo slib.texi --no-warn --no-split -o slib.info
---- slib-3b1.orig/guile.init
-+++ slib-3b1/guile.init
+--- a/guile.init
++++ b/guile.init
@@ -43,17 +43,17 @@
;;; (implementation-vicinity) should be defined to be the pathname of
;;; the directory where any auxillary files to your Scheme
diff --git a/debian/patches/do-not-regenerate-version-txi.patch b/debian/patches/do-not-regenerate-version-txi.patch
new file mode 100644
index 0000000..c1eb198
--- /dev/null
+++ b/debian/patches/do-not-regenerate-version-txi.patch
@@ -0,0 +1,16 @@
+From: Santiago Vila <sanvila@debian.org>
+Subject: Do not regenerate version.txi just because Makefile was modified
+
+--- a/Makefile
++++ b/Makefile
+@@ -206,8 +206,8 @@
+
+ ver = $(VERSION)
+ version.txi: Makefile
+- echo @set SLIBVERSION $(ver) > version.txi
+- echo @set SLIBDATE `date +"%B %Y"` >> version.txi
++ # echo @set SLIBVERSION $(ver) > version.txi
++ # echo @set SLIBDATE `date +"%B %Y"` >> version.txi
+
+ scheme = scm
+
diff --git a/debian/patches/series b/debian/patches/series
index 2850442..91c029d 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,4 @@
-debian-changes-3b1-3.1
+debian-changes.patch
712322_fix_doc_build.patch
712322_use_local_schmooz.patch
+do-not-regenerate-version-txi.patch