aboutsummaryrefslogtreecommitdiffstats
path: root/debian/patches/debian-changes.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/debian-changes.patch')
-rw-r--r--debian/patches/debian-changes.patch99
1 files changed, 99 insertions, 0 deletions
diff --git a/debian/patches/debian-changes.patch b/debian/patches/debian-changes.patch
new file mode 100644
index 0000000..8a08766
--- /dev/null
+++ b/debian/patches/debian-changes.patch
@@ -0,0 +1,99 @@
+Description: Upstream changes before switch to "3.0 (quilt)" source format in version 3b1-3.1
+Author: Jari Aalto <jari.aalto@cante.net>
+
+--- a/slib.1
++++ b/slib.1
+@@ -1,5 +1,5 @@
+ .\" dummy line
+-.TH SLIB "Dec 20 2007"
++.TH SLIB 1 "Dec 20 2007"
+ .UC 4
+ .SH NAME
+ SLIB \- Scheme Library
+--- a/slib.sh
++++ b/slib.sh
+@@ -1,4 +1,4 @@
+-
++#!/bin/bash
+ ##"slib" script; Find a Scheme implementation and initialize SLIB in it.
+ #Copyright (C) 2003, 2004 Aubrey Jaffer
+ #
+--- a/slib.texi
++++ b/slib.texi
+@@ -335,6 +335,12 @@
+ @code{macro:load}s the Scheme source file @i{<path>}.
+ @end table
+
++@c the following paragraph added by tb (Thomas Bushnell, BSG)
++@noindent
++Note that file names indicated as @i{<path>} may have ``.scm'' or
++another suffix appended to them, depending on the specific Scheme
++system you are using.
++
+
+ @node Catalog Creation, Catalog Vicinities, Library Catalogs, The Library System
+ @section Catalog Creation
+--- a/Makefile
++++ b/Makefile
+@@ -239,14 +239,14 @@
+ xpdf $(htmldir)slib.pdf
+
+ TEXI2HTML = /usr/local/bin/texi2html -split -verbose
+-slib_toc.html: version.txi slib.texi $(txifiles) $(texifiles)
++$(htmldir)slib_toc.html: version.txi slib.texi $(txifiles) $(texifiles)
+ ${TEXI2HTML} slib.texi
+ html: $(htmldir)slib_toc.html
+-$(htmldir)slib_toc.html: slib_toc.html Makefile
+- -rm -f slib_stoc.html
+- if [ -f $(PREVDOCS)slib_toc.html ]; \
+- then hitch $(PREVDOCS)slib_\*.html slib_\*.html $(htmldir); \
+- else cp slib_*.html $(htmldir);fi
++#$(htmldir)slib_toc.html: slib_toc.html Makefile
++# -rm -f slib_stoc.html
++# if [ -f $(PREVDOCS)slib_toc.html ]; \
++# then hitch $(PREVDOCS)slib_\*.html slib_\*.html $(htmldir); \
++#p else cp slib_*.html $(htmldir);fi
+
+ slib-$(VERSION).info: version.txi slib.texi $(txifiles) $(texifiles)
+ makeinfo slib.texi --no-warn --no-split -o slib.info
+--- a/guile.init
++++ b/guile.init
+@@ -43,17 +43,17 @@
+ ;;; (implementation-vicinity) should be defined to be the pathname of
+ ;;; the directory where any auxillary files to your Scheme
+ ;;; implementation reside.
+-;; (define implementation-vicinity
+-;; (let* ((path (or (%search-load-path "ice-9/q.scm")
+-;; (error "Could not find ice-9/q.scm in " %load-path)))
+-;; (vic (substring path 0 (- (string-length path) 11))))
+-;; (lambda () vic)))
++(define implementation-vicinity
++ (let* ((path (or (%search-load-path "ice-9/q.scm")
++ (error "Could not find ice-9/q.scm in " %load-path)))
++ (vic (substring path 0 (- (string-length path) 11))))
++ (lambda () vic)))
+ ;;
+ ;;; Rob Browning says %site-dir exists since Guile-1.6
+-(define implementation-vicinity
+- (cond ((and (defined? 'getenv) (getenv "GUILE_IMPLEMENTATION_PATH"))
+- => (lambda (path) (lambda () path)))
+- (else %site-dir)))
++;;(define implementation-vicinity
++;; (cond ((and (defined? 'getenv) (getenv "GUILE_IMPLEMENTATION_PATH"))
++;; => (lambda (path) (lambda () path)))
++;; (else %site-dir)))
+
+ ;;; (library-vicinity) should be defined to be the pathname of the
+ ;;; directory where files of Scheme library functions reside.
+@@ -68,7 +68,10 @@
+ (and path (substring path 0 (- (string-length path) 10))))
+ ;; Use this path if your scheme does not support GETENV
+ ;; or if SCHEME_LIBRARY_PATH is not set.
+- "/usr/lib/slib/"
++;; Changed from /usr/lib/slib to /usr/share/slib by tb@debian.org for
++;; Debian packaging.
++;; "/usr/lib/slib/"
++ "/usr/share/slib/"
+ (in-vicinity (implementation-vicinity) "slib/"))))
+ (lambda () library-path)))
+