aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rw-r--r--guile.init18
2 files changed, 16 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index d21b8a9..0fa20e3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+slib (3b1-2) unstable; urgency=low
+
+ * guile.init (implementation-vicinity): Repeat change from 3a5-2.
+ (Closes: #464143)
+
+ -- Thomas Bushnell, BSG <tb@debian.org> Thu, 07 Feb 2008 13:19:02 -0500
+
slib (3b1-1) unstable; urgency=low
* New upstream release.
diff --git a/guile.init b/guile.init
index 453e382..f89f2bf 100644
--- a/guile.init
+++ b/guile.init
@@ -43,17 +43,17 @@
;;; (implementation-vicinity) should be defined to be the pathname of
;;; the directory where any auxillary files to your Scheme
;;; implementation reside.
-;; (define implementation-vicinity
-;; (let* ((path (or (%search-load-path "ice-9/q.scm")
-;; (error "Could not find ice-9/q.scm in " %load-path)))
-;; (vic (substring path 0 (- (string-length path) 11))))
-;; (lambda () vic)))
+(define implementation-vicinity
+ (let* ((path (or (%search-load-path "ice-9/q.scm")
+ (error "Could not find ice-9/q.scm in " %load-path)))
+ (vic (substring path 0 (- (string-length path) 11))))
+ (lambda () vic)))
;;
;;; Rob Browning says %site-dir exists since Guile-1.6
-(define implementation-vicinity
- (cond ((and (defined? 'getenv) (getenv "GUILE_IMPLEMENTATION_PATH"))
- => (lambda (path) (lambda () path)))
- (else %site-dir)))
+;;(define implementation-vicinity
+;; (cond ((and (defined? 'getenv) (getenv "GUILE_IMPLEMENTATION_PATH"))
+;; => (lambda (path) (lambda () path)))
+;; (else %site-dir)))
;;; (library-vicinity) should be defined to be the pathname of the
;;; directory where files of Scheme library functions reside.