aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rw-r--r--debian/postinst8
2 files changed, 14 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 6879fa2..d367337 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+slib (3a3-2) unstable; urgency=low
+
+ * debian/postinst: If scm is installed, rebuild its slib catalog.
+
+ -- Thomas Bushnell, BSG <tb@debian.org> Sat, 27 May 2006 15:34:02 -0700
+
slib (3a3-1) unstable; urgency=low
* New upstream release. Change to guile.init for module correctness
diff --git a/debian/postinst b/debian/postinst
index 7a50001..7aa2898 100644
--- a/debian/postinst
+++ b/debian/postinst
@@ -23,6 +23,14 @@ if [ -x /usr/bin/guile-1.6 -a -e /usr/share/guile/1.6/slib ] ; then
fi
fi
+if [ -x /usr/bin/scm ] ; then
+ rm -f /usr/lib/scm/slibcat
+ /usr/bin/scm -c "(require 'new-catalog)"
+ if [ -e /usr/lib/scm/slibcat ] ; then
+ chmod 644 /usr/lib/scm/slibcat
+ fi
+fi
+
# doc base support
if [ "$1" = configure ]; then
if command -v install-docs >/dev/null 2>&1; then