summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/changelog16
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules10
-rw-r--r--debian/slib.lintian-overrides5
-rwxr-xr-xslib.sh2
5 files changed, 30 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index dc894b3..5a2b993 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,19 @@
+slib (3a5-3) unstable; urgency=low
+
+ * debian/rules (binary-arch): Don't do anything here. Fixes lintian
+ warning binary-arch-rules-but-pkg-is-arch-indep.
+
+ * debian/control (Standards-Version): Update to 3.7.3. No changes needed.
+
+ * slib.sh: Specify #!/bin/sh.
+
+ * debian/slib.lintian-overrides: New file. Don't complain about the
+ usr/share/slib/init symlink.
+ * debian/rules (binary-indep): Install slib.lintian-overrides as
+ usr/share/lintian/overrides/slib in the final package.
+
+ -- Thomas Bushnell, BSG <tb@debian.org> Mon, 14 Jan 2008 16:41:39 -0500
+
slib (3a5-2) unstable; urgency=low
* debian/rules (binary-indep): init subdir symlink should point to ".",
diff --git a/debian/control b/debian/control
index 602f040..1633470 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: devel
Priority: optional
Maintainer: Thomas Bushnell, BSG <tb@debian.org>
Build-Depends-Indep: scm, texi2html, texinfo
-Standards-Version: 3.7.2
+Standards-Version: 3.7.3
Package: slib
Section: devel
diff --git a/debian/rules b/debian/rules
index dfbb14c..856fc6b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -43,7 +43,7 @@ clean:
-rm -f .slibcat
binary-arch: checkroot
- $(checkdir)
+# $(checkdir)
binary-indep: checkroot build
$(checkdir)
@@ -90,13 +90,17 @@ binary-indep: checkroot build
# slibconfig
- #$(INSTALL_DIR) debian/tmp/usr/sbin
- #$(INSTALL_PROGRAM) debian/slibconfig debian/tmp/usr/sbin
+# $(INSTALL_DIR) debian/tmp/usr/sbin
+# $(INSTALL_PROGRAM) debian/slibconfig debian/tmp/usr/sbin
# program
$(INSTALL_DIR) debian/tmp/usr/bin
$(INSTALL_PROGRAM) slib.sh debian/tmp/usr/bin/slib
+# lintian
+ $(INSTALL_DIR) debian/tmp/usr/share/lintian/overrides
+ $(INSTALL_DATA) debian/slib.lintian-overrides debian/tmp/usr/share/lintian/overrides/slib
+
dpkg-gencontrol -is -ip
dpkg --build debian/tmp ..
diff --git a/debian/slib.lintian-overrides b/debian/slib.lintian-overrides
new file mode 100644
index 0000000..3eb0ce7
--- /dev/null
+++ b/debian/slib.lintian-overrides
@@ -0,0 +1,5 @@
+# The recursive link usr/share/slib is not a mistake; it is a necessary
+# backwards compatibility from the days when we put all the init files
+# in a separate subdir. That was never the Right Thing to do, but this
+# helps out other packages.
+slib binary: symlink-is-self-recursive usr/share/slib/init .
diff --git a/slib.sh b/slib.sh
index 6948389..6550071 100755
--- a/slib.sh
+++ b/slib.sh
@@ -1,4 +1,4 @@
-
+#!/bin/sh
##"slib" script; Find a Scheme implementation and initialize SLIB in it.
#Copyright (C) 2003, 2004 Aubrey Jaffer
#