diff options
author | Thomas Bushnell, BSG <tb@debian.org> | 2007-12-28 16:25:32 -0800 |
---|---|---|
committer | Bryan Newbold <bnewbold@robocracy.org> | 2017-02-20 00:05:39 -0800 |
commit | d8ae23691ed6392b7f320f5fa7d4dd78ae52c10e (patch) | |
tree | b20b8bc02e854c4c86d39ee22a0638a8b06e01af /vscm.init | |
parent | edd1ebef3ad774e7cbcc2f5918d555bfb0b44091 (diff) | |
parent | 64f037d91e0c9296dcaef9a0ff3eb33b19a2ed34 (diff) | |
download | slib-d8ae23691ed6392b7f320f5fa7d4dd78ae52c10e.tar.gz slib-d8ae23691ed6392b7f320f5fa7d4dd78ae52c10e.zip |
Import Debian changes 3a5-1debian/3a5-1
slib (3a5-1) unstable; urgency=low
* New upstream release.
* slib.texi (Library Catalogs): Repeat change from 3a3-3.
* Makefile: Repeat $(htmldir)slib_toc.html changes from 3a2-1.
* guile.init: (library-vicinity): Repeat change from 3a4-2.
* debian/rules (binary-indep): Don't hide .init files in a separate
subdirectory, thus conforming better to the usual slib practice. Put a
symlink in place to ease transitions. (Closes: #407370).
Diffstat (limited to 'vscm.init')
-rw-r--r-- | vscm.init | 13 |
1 files changed, 9 insertions, 4 deletions
@@ -237,9 +237,15 @@ ;;; (define (program-arguments) command-line-arguments) -;;; (OUTPUT-PORT-WIDTH <port>) +;;@ (FILE-POSITION <port> . <k>) +(define (file-position . args) #f) + +;;@ (OUTPUT-PORT-WIDTH <port>) (define (output-port-width . arg) 79) +;;@ (OUTPUT-PORT-HEIGHT <port>) +(define (output-port-height . arg) 24) + ;;; (CURRENT-ERROR-PORT) (define (current-error-port) (standard-port 2)) @@ -251,11 +257,10 @@ ;;; (FILE-EXISTS? <string>) (define (file-exists? f) - (system (string-append "test -f " f))) + (system (string-append "test -f '" f "'"))) ;;; (DELETE-FILE <string>) -(define (delete-file f) - (remove-file f)) +(define delete-file remove-file) ;;; FORCE-OUTPUT flushes any pending output on optional arg output port (define force-output flush) |