summaryrefslogtreecommitdiffstats
path: root/top-refs.txi
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2005-01-10 08:53:33 +0000
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:30 -0800
commite33f9eb9cf5cc29c36ce2aa7e10cd0f37ae0cc8e (patch)
treeabbf06041619e445f9d0b772b0d58132009d8234 /top-refs.txi
parentf559c149c83da84d0b1c285f0298c84aec564af9 (diff)
parent8466d8cfa486fb30d1755c4261b781135083787b (diff)
downloadslib-263aa0869bf58367a115a366c58ebcaea7f5ea58.tar.gz
slib-263aa0869bf58367a115a366c58ebcaea7f5ea58.zip
Import Debian changes 3a1-4.2debian/3a1-4.2
slib (3a1-4.2) unstable; urgency=low * Non-maintainer upload. * Add guile.init.local for use within the build dir, since otherwise we have an (earlier unnoticed) circular build-dep due to a difference between scm and guile. slib (3a1-4.1) unstable; urgency=low * Non-maintainer upload. * Build-depend on guile-1.6 instead of scm, since the new version of scm is wedged in unstable (closes: #281809). slib (3a1-4) unstable; urgency=low * Also check for expected creation on slibcat. (Closes: #240096) slib (3a1-3) unstable; urgency=low * Also check for /usr/share/guile/1.6/slib before installing for guile 1.6. (Closes: #239267) slib (3a1-2) unstable; urgency=low * Add format.scm back into slib until gnucash stops using it. * Call guile-1.6 new-catalog (Closes: #238231) slib (3a1-1) unstable; urgency=low * New upstream release * Remove Info section from doc-base file (Closes: #186950) * Remove period from end of description (linda, lintian) * html gen fixed upstream (Closes: #111778) slib (2d4-2) unstable; urgency=low * Fix url for upstream source (Closes: #144981) * Fix typo in slib.texi (enquque->enqueue) (Closes: #147475) * Add build depends. slib (2d4-1) unstable; urgency=low * New upstream. slib (2d3-1) unstable; urgency=low * New upstream. * Remove texi2html call in debian/rules. Now done upstream. Add make html instead. * Changes to rules and doc-base to conform to upstream html gen * Clean up upstream makefile to make sure it cleans up after itself.
Diffstat (limited to 'top-refs.txi')
-rw-r--r--top-refs.txi65
1 files changed, 65 insertions, 0 deletions
diff --git a/top-refs.txi b/top-refs.txi
new file mode 100644
index 0000000..11944bb
--- /dev/null
+++ b/top-refs.txi
@@ -0,0 +1,65 @@
+@code{(require 'top-refs)}
+@ftindex top-refs
+@cindex top-level variable references
+@cindex variable references
+
+@noindent
+These procedures complement those in @ref{Module Manifests} by
+finding the top-level variable references in Scheme source code.
+They work by traversing expressions and definitions, keeping track
+of bindings encountered. It is certainly possible to foil these
+functions, but they return useful information about SLIB source
+code.
+
+
+@defun top-refs obj
+
+Returns a list of the top-level variables referenced by the Scheme
+expression @var{obj}.
+@end defun
+
+@defun top-refs<-file filename
+
+@var{filename} should be a string naming an existing file containing Scheme
+source code. @code{top-refs<-file} returns a list of the top-level variable references
+made by expressions in the file named by @var{filename}.
+
+Code in modules which @var{filename} @code{require}s is not traversed. Code in
+files loaded from top-level @emph{is} traversed if the expression
+argument to @code{load}, @code{slib:load}, @code{slib:load-source},
+@code{macro:load}, @code{defmacro:load}, @code{synclo:load},
+@code{syncase:load}, or @code{macwork:load} is a literal string
+constant or composed of combinations of vicinity functions and
+string literal constants; and the resulting file exists (possibly
+with ".scm" appended).
+@end defun
+@noindent
+The following function parses an @dfn{Info} Index.
+@cindex Info
+@footnote{Although it will
+work on large info files, feeding it an excerpt is much faster; and
+has less chance of being confused by unusual text in the info file.
+This command excerpts the SLIB index into @file{slib-index.info}:
+
+@example
+info -f slib2d6.info -n "Index" -o slib-index.info
+@end example
+}
+
+
+@defun exports<-info-index file n @dots{}
+
+@var{n} @dots{} must be an increasing series of positive integers.
+@code{exports<-info-index} returns a list of all the identifiers appearing in the @var{n}th
+@dots{} (info) indexes of @var{file}. The identifiers have the case that
+the implementation's @code{read} uses for symbols. Identifiers
+containing spaces (eg. @code{close-base on base-table}) are
+@emph{not} included.
+
+Each info index is headed by a @samp{* Menu:} line. To list the
+symbols in the first and third info indexes do:
+
+@example
+(exports<-info-index "slib.info" 1 3)
+@end example
+@end defun