aboutsummaryrefslogtreecommitdiffstats
path: root/priorque.scm
diff options
context:
space:
mode:
authorJim Pick <jim@jimpick.com>1998-03-08 23:05:22 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:27 -0800
commitb21cac3362022718634f7086964208b2eed8e897 (patch)
tree16f4b2e70645c0e8e2202023170b5a94baa967e3 /priorque.scm
parent3796d2595035e192ed4bf1c9a6bfdb13c3c9d261 (diff)
parentf24b9140d6f74804d5599ec225717d38ca443813 (diff)
downloadslib-b21cac3362022718634f7086964208b2eed8e897.tar.gz
slib-b21cac3362022718634f7086964208b2eed8e897.zip
Import Debian changes 2c0-3debian/2c0-3
slib (2c0-3) unstable; urgency=low * New maintainer. * slibconfig script to automatically configure guile. * Fix type in description, closes: Bug#18996 slib (2c0-2) unstable; urgency=low * Minor fix for debian/rules targets slib (2c0-1) unstable; urgency=low * New upstream source * New maintainer
Diffstat (limited to 'priorque.scm')
-rw-r--r--priorque.scm13
1 files changed, 4 insertions, 9 deletions
diff --git a/priorque.scm b/priorque.scm
index 927ffbe..9002c01 100644
--- a/priorque.scm
+++ b/priorque.scm
@@ -1,5 +1,5 @@
;;;; "priorque.scm" priority queues for Scheme.
-;;; Copyright (C) 1992, 1993 Aubrey Jaffer.
+;;; Copyright (C) 1992, 1993, 1994, 1995, 1997 Aubrey Jaffer.
;
;Permission to copy this software, to redistribute it, and to use it
;for any purpose is granted, subject to the following restrictions and
@@ -131,11 +131,6 @@
(heap-insert! heap #\Q)
(heap-insert! heap #\S)
(heap-insert! heap #\R)
- (print (heap-extract-max! heap))
- (print (heap-extract-max! heap))
- (print (heap-extract-max! heap))
- (print (heap-extract-max! heap))
- (print (heap-extract-max! heap))
- (print (heap-extract-max! heap))
- (print (heap-extract-max! heap))
- (print (heap-extract-max! heap))))
+ (do ((i 7 (+ -1 i)))
+ ((negative? i))
+ (write (heap-extract-max! heap)) (newline))))